summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-25 19:40:13 +0100
committerSam James <sam@gentoo.org>2021-09-25 20:07:43 +0100
commit4c225f25b7cb28e6d45d470ca4cf2ce055a559eb (patch)
tree89b6d1377df8408c1b6a7e2d01d0ce93486628d5 /net-p2p/cpuminer-opt/cpuminer-opt-3.16.4.ebuild
parentdev-libs/jansson: version bump to 2.14 (diff)
downloadgentoo-4c225f25b7cb28e6d45d470ca4cf2ce055a559eb.tar.gz
gentoo-4c225f25b7cb28e6d45d470ca4cf2ce055a559eb.tar.bz2
gentoo-4c225f25b7cb28e6d45d470ca4cf2ce055a559eb.zip
net-p2p/cpuminer-opt: add libjansson subslot dep
Earlier versions of libjansson lacked symbol versioning, causing crashes. Bug: https://bugs.gentoo.org/812119 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/cpuminer-opt/cpuminer-opt-3.16.4.ebuild')
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.16.4.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.16.4.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.16.4.ebuild
deleted file mode 100644
index fb5ffe94cd29..000000000000
--- a/net-p2p/cpuminer-opt/cpuminer-opt-3.16.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic systemd
-
-DESCRIPTION="Optimized multi algo CPU miner"
-HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
-IUSE="cpu_flags_x86_sse2 curl"
-LICENSE="GPL-2"
-SLOT="0"
-REQUIRED_USE="cpu_flags_x86_sse2"
-DEPEND="
- dev-libs/gmp:0
- dev-libs/jansson
- >=net-misc/curl-7.15[ssl]
- dev-libs/openssl:0=
-"
-RDEPEND="${DEPEND}"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- append-ldflags -Wl,-z,noexecstack
- econf --with-crypto --with-curl
-}
-
-src_install() {
- default
- systemd_dounit "${FILESDIR}"/${PN}.service
- insinto "/etc/${PN}"
- doins cpuminer-conf.json
-}
-
-src_test() {
- ./cpuminer --cputest || die
-}