summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2017-11-07 22:07:22 +0100
committerCraig Andrews <candrews@gentoo.org>2017-12-20 14:47:13 -0500
commita2a33bd25f85a13938d56574b43a1d9234b7b581 (patch)
tree3724ee490c8a12690677f85accf45480d329fbcf /net-p2p/go-ethereum
parentmedia-video/simplescreenrecorder: Fixed pulseaudio check. (diff)
downloadgentoo-a2a33bd25f85a13938d56574b43a1d9234b7b581.tar.gz
gentoo-a2a33bd25f85a13938d56574b43a1d9234b7b581.tar.bz2
gentoo-a2a33bd25f85a13938d56574b43a1d9234b7b581.zip
net-p2p/go-ethereum: version bump to 1.7.2
This ebuild replaces the evm useflag with the devtools use flag which installs all the development tools (including evm) Closes: https://bugs.gentoo.org/621482 Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'net-p2p/go-ethereum')
-rw-r--r--net-p2p/go-ethereum/Manifest1
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.7.2.ebuild40
-rw-r--r--net-p2p/go-ethereum/metadata.xml1
3 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index 5d38b59f114e..e9c35c2d0ed4 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1 +1,2 @@
DIST go-ethereum-1.5.5.tar.gz 14957844 BLAKE2B fcea479dd0ab9ffd8c0ff80b55913bc543d7827edf43c2f3a3d9f262433edf4a792e0229df8f744e8436d4d93e0161d1fa60125c09a7eeacba90b556a481830b SHA512 4429d0aaceb0e6ffa92f85674ad50ddb092436b97fabb4ff09439c408a762155ae7077b0a69432cf4a2397aea2ff3c4d603713ea1cd304a831b8aa9c039314ea
+DIST go-ethereum-1.7.2.tar.gz 7037907 BLAKE2B eb1e358e42c743a931995e7ee46dc2441356159fc9095e8a886cc6a0495cb2d2e77ee7df4c6dd98bc790397819fc43cdedba6cf28de1e4f3dcdc4dd71106f8e5 SHA512 7bc5957f1523fa5ec67650c4305633aa4c6098a243ef415f9ef56a4e4763eb2ef9f69514ed15810fcdb75f11e87cbd27c4f2af802c32a03be91b37a7b08ea520
diff --git a/net-p2p/go-ethereum/go-ethereum-1.7.2.ebuild b/net-p2p/go-ethereum/go-ethereum-1.7.2.ebuild
new file mode 100644
index 000000000000..04e769b1b60b
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools opencl"
+
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ use opencl && export GO_OPENCL=true
+
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ if use devtools; then
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/evm
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ dobin build/bin/swarm
+ dobin build/bin/wnode
+ fi
+}
diff --git a/net-p2p/go-ethereum/metadata.xml b/net-p2p/go-ethereum/metadata.xml
index 3056bf45f275..a9fe60633bd3 100644
--- a/net-p2p/go-ethereum/metadata.xml
+++ b/net-p2p/go-ethereum/metadata.xml
@@ -11,6 +11,7 @@
</maintainer>
<use>
<flag name="evm">Build Ethereum Virtual Machine (EVM)</flag>
+ <flag name="devtools">Build Ethereum development tools (evm, abigen, puppeth, ...)</flag>
<flag name="opencl">Add OpenCL GPU mining support</flag>
</use>
<upstream>