summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-09 09:13:06 +0200
committerHans de Graaff <graaff@gentoo.org>2015-10-10 07:38:43 +0200
commitd8bf6d4ccadc938299566911ae9010f9bfa3c0b6 (patch)
treefe8afb016d14b7f6c602672f00f61946dc543900 /net-p2p/gtk-gnutella
parentdev-ruby/bson: add 3.2.6 (diff)
downloadgentoo-d8bf6d4ccadc938299566911ae9010f9bfa3c0b6.tar.gz
gentoo-d8bf6d4ccadc938299566911ae9010f9bfa3c0b6.tar.bz2
gentoo-d8bf6d4ccadc938299566911ae9010f9bfa3c0b6.zip
net-p2p/gtk-gnutella: add 1.1.5
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-p2p/gtk-gnutella')
-rw-r--r--net-p2p/gtk-gnutella/Manifest1
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.1.5.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-p2p/gtk-gnutella/Manifest b/net-p2p/gtk-gnutella/Manifest
index 610d26d4ec07..85b9e2b70752 100644
--- a/net-p2p/gtk-gnutella/Manifest
+++ b/net-p2p/gtk-gnutella/Manifest
@@ -1,2 +1,3 @@
DIST gtk-gnutella-1.1.3.tar.bz2 19504243 SHA256 2659ddb846f60d13789674e926a71bbb4a8b9d3ca98c6b034a95eaa073531405 SHA512 df143b6e89b0a4c6e8ddbba24ddcab3603f04e7df1fab7d389241a112c6cd3297e4837dfc0d225289997b99867a5466a5b8697c68ef2bdc5817261fbc103d505 WHIRLPOOL fe1a1375e75204bdf92c9690f1885211dc456c2cc466f4d7e47c865fc0e1c77ce07d27b58ff2e53c4c28214d055878c7d805f0b79043748e1448c6b8ac398c82
DIST gtk-gnutella-1.1.4.tar.bz2 19546318 SHA256 6ae259ff9d5f20a2d10dba66ed6cbe5b56552307a6e8bc36df053b70aff4c956 SHA512 e09fde0e1f8a701e099f91768e032d022f6e9d41cdb4cc7833f1e7ba0e2795bc102c6b835960eb69e577ffc1426c42f6e1682ebadb8c5a643a796f88ff204ac6 WHIRLPOOL a9e63865896444c2ba22e9cf4302f5da5f6bdcec257cc87c618c3c3514cbf924e0eb6df7909b21ad5798650a577adf38cb37806810fd3f6a7f67be5f7a7cc8f1
+DIST gtk-gnutella-1.1.5.tar.bz2 19552392 SHA256 c332043a885ba302841a261c118264d903627fd21b062c99538db7dc7dada8a5 SHA512 eb94ef5cbc447ebf75d16eb24f0a4d88197a9b79f842fe73f963af3ba5985cc4ce99605d29e33123754d9a509218b71acc684df27a075c3947278211c1b204e5 WHIRLPOOL c5bc302dd7bd92eac2298c52b557723b473a930a7e1b40cddc74424bef7acf0a9b90f27ba503dc40038c925047dfcf6f80ca8de2f0e20a6429d70267de3ada49
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.1.5.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.5.ebuild
new file mode 100644
index 000000000000..154b509fd546
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ strip-linguas -i po
+
+ echo "# Gentoo-selected LINGUAS" > po/LINGUAS
+ for ling in ${LINGUAS}; do
+ echo $ling >> po/LINGUAS
+ done
+}
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_compile() {
+ # Build system is not parallel-safe, bug 500760
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}