summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-05-11 16:02:32 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-05-11 16:03:26 +0300
commit29528824ac000cb50657e5128a2c2c9e25851f91 (patch)
tree6acac2d3291cfb2cc1872168b2b8344f7b775238 /net-p2p/qbittorrent
parentnet-misc/putty: Drop AM_PATH_GTK line removal workaround (diff)
downloadgentoo-29528824ac000cb50657e5128a2c2c9e25851f91.tar.gz
gentoo-29528824ac000cb50657e5128a2c2c9e25851f91.tar.bz2
gentoo-29528824ac000cb50657e5128a2c2c9e25851f91.zip
net-p2p/qbittorrent: Version bump (4.1.6)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.1.6.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 841311e87c1c..ebadfc60b86b 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,2 +1,3 @@
DIST qbittorrent-4.1.4.tar.gz 7718217 BLAKE2B 46fc3ad230a74cc2f05bdfe5f53b6b39e0dcd99afff941614345ef1d85492f647080a6111c403f30746b24d1b03e1a6fd196015c7646dc5ab5c73027a8c8c5b8 SHA512 2621a9b6a19609bafd2d99336e5dc4c5f4aef9e5ab6ecebd9c622c759cdcea2a18999c08a70ac32d88fbd65c310749ea2254562152c1d3886285aa7c5c86bf68
DIST qbittorrent-4.1.5.tar.gz 7719557 BLAKE2B d849227443843684d16ba93e65a64b2d637f1ce41c2f5c3a1ee46db74c7497d0d3cb6b627bfee79ce2e4f2b99ee252287b584542cd47003a1055a43bf0f63cfc SHA512 e090ecc9343ff94874a6d54d487a672dcd44a943da4e2d625b5f7db849c861173c12c870f4d7f0843a60fdffd1fbbd74d05d48223bd3ebf32b7a1ef478c95dec
+DIST qbittorrent-4.1.6.tar.gz 7780676 BLAKE2B fe2572bece5a014d821cf905a13a45f71c63eda661b338a90517a23d257d83f556c1ad1bd064cc2840e9731886d7afaafa36ea50f8c3fe8ff05fc3ec3a12c478 SHA512 14c337257a71a7a6f850bbbbe3effe6f34c299fe71486c1a71160f54ccc7377a5c8e742ca2fd85cf198b2a603fdfee50bdb19b33a10899f86f8499468ca8a735
diff --git a/net-p2p/qbittorrent/qbittorrent-4.1.6.ebuild b/net-p2p/qbittorrent/qbittorrent-4.1.6.ebuild
new file mode 100644
index 000000000000..30188ae78c36
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.1.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
+ dev-qt/qtxml:5
+ =net-libs/libtorrent-rasterbar-1.1*:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf --with-qtsingleapplication=system \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}