summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-04-23 20:41:58 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-04-23 20:42:57 +0200
commit1550c1b68365047359a2e4b888205b2ff87c387f (patch)
tree88bc3392cfc8dd0eed4b94164df223d074fa5c37 /net-p2p/torrentinfo
parentmail-mta/msmtp: Bump to version 1.8.10 (diff)
downloadgentoo-1550c1b68365047359a2e4b888205b2ff87c387f.tar.gz
gentoo-1550c1b68365047359a2e4b888205b2ff87c387f.tar.bz2
gentoo-1550c1b68365047359a2e4b888205b2ff87c387f.zip
net-p2p/torrentinfo: add Python 3.8 support, fix dependencies
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p/torrentinfo')
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
index fb9696112136..47fe1ceaf026 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# The package uses distutils
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -17,7 +19,6 @@ IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"