summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-05-30 17:17:38 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-05-30 17:20:13 -0500
commit631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6 (patch)
treed90021adeade17015dca1c89511c4b389cbb8071 /net-p2p/tremc/tremc-0.9.3.ebuild
parentnet-p2p/arti: drop 0.1.0, 0.2.0 (diff)
downloadgentoo-631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6.tar.gz
gentoo-631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6.tar.bz2
gentoo-631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6.zip
net-p2p/tremc: add 0.9.3
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-p2p/tremc/tremc-0.9.3.ebuild')
-rw-r--r--net-p2p/tremc/tremc-0.9.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/tremc/tremc-0.9.3.ebuild b/net-p2p/tremc/tremc-0.9.3.ebuild
new file mode 100644
index 000000000000..f08595a9ba3e
--- /dev/null
+++ b/net-p2p/tremc/tremc-0.9.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 optfeature python-single-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/tremc/tremc"
+SRC_URI="https://github.com/tremc/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="8b6b29163295e5cf12d9d874e80203c5906619c8"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+# Github tag tarballs include the repo with commit in the dir's name
+# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript tremc
+ newbashcomp completion/bash/tremc.sh tremc
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_tremc
+ doman tremc.1
+ dodoc NEWS README.md
+}
+
+pkg_postinst() {
+ optfeature "GeoIP support" dev-python/geoip-python
+ optfeature "Extract ipv4 from ipv6 addresses" dev-python/ipy
+ optfeature "Clipboard support" dev-python/pyperclip
+}