summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2019-03-15 19:27:06 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-03-15 23:42:17 +0100
commit6edfbc0131d0532ef84dc6751e778ed2dd1480b3 (patch)
tree20a327caa12d28324df63aa88cbb4610ae0dd94e /net-p2p
parentnet-p2p/resilio-sync: remove old version 2.5.12. (diff)
downloadgentoo-6edfbc0131d0532ef84dc6751e778ed2dd1480b3.tar.gz
gentoo-6edfbc0131d0532ef84dc6751e778ed2dd1480b3.tar.bz2
gentoo-6edfbc0131d0532ef84dc6751e778ed2dd1480b3.zip
net-p2p/resilio-sync: version bump to 2.6.3, EAPI 7.
1. Version bump to 2.6.3 2. Moved to EAPI 7 3. Upstream changed URL Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/resilio-sync/Manifest2
-rw-r--r--net-p2p/resilio-sync/resilio-sync-2.6.3.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/net-p2p/resilio-sync/Manifest b/net-p2p/resilio-sync/Manifest
index a85e4ac47e2a..815fa8be8b56 100644
--- a/net-p2p/resilio-sync/Manifest
+++ b/net-p2p/resilio-sync/Manifest
@@ -1,2 +1,4 @@
DIST resilio-sync_2.6.1-1_amd64.deb 11576892 BLAKE2B 710bd96b91be84bc7210d8efe0d8954a33be878fc948694e7a1c62e7b53b5ac94133a16b89c4872e18798bc03f3508c7c130d4d56a3480c35d30edff5589ef3a SHA512 a37d73a621a740f57b4f2824cc2a3178f365ccc8180a0e814480dde8d1b74b9d54da4e07bd18c89cc6a93c12b526f8a43e08165d3c2f0fdc913e1f38e46eb183
DIST resilio-sync_2.6.1-1_i386.deb 11465194 BLAKE2B b56e01f79c5beec6a5ebd09724bebd1ce8c6d44eac694cd7fb89dc44823ccba22531b14e241fdd985ae63e6e0f177021becb593923eac8ac0183629e533ac72d SHA512 84676c3fe5fcee484bcd58c6496aba0d2e3c86c339adb90b8b3cef28ae46d7b6f28c5fd0371a2cfe612ab8b3658eca2b9b2f6cfc9caa70aaff95946942a5c749
+DIST resilio-sync_2.6.3-1_amd64.deb 12109918 BLAKE2B e89ca0eedadd29d1d0519f0e894f6cbb865b39600df6b516a85411da45e58751caf1c0988d13c821b134ac2318f6487cdad82a75b7357686bde1865b88779f3e SHA512 4531936a5ddd23cfcf2354ea9c7f285e08d1afdd0922d1254baec2900f1c4bfdbbe5d57a5f9cf079b8b3fee69cc9f0a1557218657c1386f800d6e19cc6de31a3
+DIST resilio-sync_2.6.3-1_i386.deb 12062106 BLAKE2B f070844fc513ce052e1cb480f4b521216da485ffc00fb0b7e512d877ae6d0bb39452015bc24f931850542490e69d3b210c5a4dd8635a43f16901791144134880 SHA512 18e01ae12c198e7e921a8fd74e934365f027607940ada7378adb239b5c8a25b94e47ac4290c738acac54c53beff25e1ba35f4e079ce8145852f385212bd8794b
diff --git a/net-p2p/resilio-sync/resilio-sync-2.6.3.ebuild b/net-p2p/resilio-sync/resilio-sync-2.6.3.ebuild
new file mode 100644
index 000000000000..95ea559330a0
--- /dev/null
+++ b/net-p2p/resilio-sync/resilio-sync-2.6.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles unpacker user
+
+QA_PREBUILT="usr/bin/rslsync"
+BASE_URI="http://download-cdn.resilio.com/${PV}/Debian/${PN}_${PV}-1_@arch@.deb"
+
+DESCRIPTION="Resilient, fast and scalable file synchronization tool"
+HOMEPAGE="https://resilio.com/"
+SRC_URI="amd64? ( ${BASE_URI/@arch@/amd64} )
+ x86? ( ${BASE_URI/@arch@/i386} )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel"
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}"
+
+DOC_CONTENTS="You may need to review /etc/resilio-sync/config.json\\n
+Default metadata path is /var/lib/resilio-sync/.sync\\n
+Default web-gui URL is http://localhost:8888/\\n\\n"
+
+pkg_setup() {
+ enewgroup rslsync
+ enewuser rslsync -1 -1 /var/lib/resilio-sync rslsync
+}
+
+src_unpack() {
+ unpacker_src_unpack
+
+ unpack usr/share/man/man1/resilio-sync.1.gz
+}
+
+src_install() {
+ dobin usr/bin/rslsync
+ use pax_kernel && pax-mark m "${ED%/}"/usr/bin/rslsync
+
+ doman resilio-sync.1
+
+ newinitd "${FILESDIR}"/resilio-sync.initd resilio-sync
+ newconfd "${FILESDIR}"/resilio-sync.confd resilio-sync
+ newinitd "${FILESDIR}"/resilio-sync-user.initd resilio-sync-user
+ newconfd "${FILESDIR}"/resilio-sync-user.confd resilio-sync-user
+ systemd_dounit "${FILESDIR}"/resilio-sync.service
+ systemd_douserunit "${FILESDIR}"/resilio-sync-user.service
+ newtmpfiles "${FILESDIR}"/resilio-sync.tmpfile resilio-sync.conf
+
+ readme.gentoo_create_doc
+
+ # Generate sample config, uncomment config directives and change values
+ insopts -orslsync -grslsync -m0644
+ insinto /etc/resilio-sync
+ newins - config.json < <("${ED%/}"/usr/bin/rslsync --dump-sample-config | \
+ sed \
+ -e "/storage_path/s|//| |g" \
+ -e "/pid_file/s|//| |g" \
+ -e "/storage_path/s|/home/user/.sync|/var/lib/resilio-sync/.sync|g" \
+ -e "/pid_file/s|resilio/resilio|resilio-sync/resilio-sync|g" \
+ || die "sed failed for config.json" )
+
+ diropts -orslsync -grslsync -m0700
+ keepdir /etc/resilio-sync /var/lib/resilio-sync/ \
+ /var/lib/resilio-sync/.sync /var/log/resilio-sync
+}
+
+pkg_postinst() {
+ tmpfiles_process resilio-sync.conf
+ readme.gentoo_print_elog
+}