summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-05-05 03:07:15 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-05-05 03:07:15 +0200
commitc828950299c1f83f8e60b3c013aa043fcc64c8ed (patch)
tree621bb520a785914e6b539570bf261228986f348d /net-p2p
parentdev-qt/qtwebkit: fix linking against libpthread (diff)
downloadgentoo-c828950299c1f83f8e60b3c013aa043fcc64c8ed.tar.gz
gentoo-c828950299c1f83f8e60b3c013aa043fcc64c8ed.tar.bz2
gentoo-c828950299c1f83f8e60b3c013aa043fcc64c8ed.zip
net-p2p/qbittorrent: sync live ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index c98d0ca8a65f..70a4b9642c57 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit qmake-utils
+inherit flag-o-matic qmake-utils
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
@@ -58,6 +58,12 @@ DEPEND="${RDEPEND}
DOCS=(AUTHORS Changelog CONTRIBUTING.md README.md TODO)
src_configure() {
+ # workaround build issue with older boost
+ # https://github.com/qbittorrent/qBittorrent/issues/4112
+ if has_version '<dev-libs/boost-1.58'; then
+ append-cppflags -DBOOST_NO_CXX11_REF_QUALIFIERS
+ fi
+
econf \
--with-qjson=system \
--with-qtsingleapplication=system \