summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-05-14 10:21:16 -0400
committerCraig Andrews <candrews@gentoo.org>2018-05-14 10:21:37 -0400
commitf5e0f303849cfaae98dad56d3f47a547d5942447 (patch)
tree4246eadd68d4825bc703d5a523ebe904ec9d4230 /net-p2p
parentapp-emulation/free42: Drop old version 2.0.17 (diff)
downloadgentoo-f5e0f303849cfaae98dad56d3f47a547d5942447.tar.gz
gentoo-f5e0f303849cfaae98dad56d3f47a547d5942447.tar.bz2
gentoo-f5e0f303849cfaae98dad56d3f47a547d5942447.zip
net-p2p/cpuminer-opt: 3.8.8.1 version bump
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 4d563c8d2850..80a0c37a7ca9 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -5,4 +5,5 @@ DIST cpuminer-opt-3.8.6.tar.gz 1701535 BLAKE2B ed51168879e6ca6ada67f13b7325b36c8
DIST cpuminer-opt-3.8.7.1.tar.gz 1707776 BLAKE2B 134c25fab106db6fad601010f8f91a82e42bc03b94e633ffd3db3ef3d4eb05f2561e1249c06f3505a03abbb95976ebfcbcbad225166bc2208a123df15859036a SHA512 74cd569718cf8402cb25a4be4e9d94a897a697e02c7c9f6422313c3a3026f3d12a8eea9669b3a253fdfb471311bf49f8209f35efacb84fd3151e4ac8acda2ed7
DIST cpuminer-opt-3.8.7.2.tar.gz 1707968 BLAKE2B 2358286014b631fea94f49de5ccb61477c0b388c650a87734ee684781ddc0f0cbdbb539affce6c12da8a4ca91a132f8ca9a4ba923c971d0ddca8e712276899ec SHA512 857a91a1061d9d4921af94743faee03031e8f2e92ba2e1d885dbd1060b19d6b93d28e9f54d10e59930eb0c8ebdb19db9888aca9ce0a05e7fbbb659d3ae3e25b5
DIST cpuminer-opt-3.8.7.tar.gz 1707993 BLAKE2B c1a3156c02a3adf80b75fd6766c3bb7d20755813f90b2669ff6d462990ef2b80a97218b0a30fb559c8c2b3902bdc194e01f463351778f6fbd2a8a08c44da3e81 SHA512 c2aee02586712591d609748e5dbf90d5e28050fa4611915e216a6fef79fdb7ea2e0c31b844457fd505f2cc6892268dbcaebe3ed6b00f2efe9734c8d19ba8096a
+DIST cpuminer-opt-3.8.8.1.tar.gz 1709515 BLAKE2B cecf9f57093fd89cef459cdc0d591a5de4bb12126a931dd9bfee0fc9b08a7ec4b5bb087ad383f14492b3da3066bac695f0022e1dfc595c7e331c9517b4b44db6 SHA512 5dd254237231abb84312c31be97952d1e1f1cd6c4fa0efc409581afb1a28d9783816b9efdb07501d67b99b831bce0a290e5cc2b3ce6c915a3e76b00edd582560
DIST cpuminer-opt-3.8.8.tar.gz 1708920 BLAKE2B 7f05890a0598737d070429617952aa4fc782c960f724a627938855336503d03c198902d63eb9d1563aece56ab354d339a2d8dbc91c7162c83ddaffc8a3de8cd2 SHA512 24f1521660b1d2974328674bfd63ca34628ac005e7f6de111a6b82a588f4f4d8e809d78e374ad9e97910b73c0af961e1c4a1c07c4d494bb200be4697fa143acc
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}