summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2017-12-04 22:55:33 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-04 23:08:32 +0100
commitfac4da0c154b62802de249b11eabec4c9081f3d2 (patch)
treede87e3d822e2f93f8eda10e8899ebbd07ede6614 /net-p2p
parentnet-p2p/mktorrent: Add myself as proxied maintainer. (diff)
downloadgentoo-fac4da0c154b62802de249b11eabec4c9081f3d2.tar.gz
gentoo-fac4da0c154b62802de249b11eabec4c9081f3d2.tar.bz2
gentoo-fac4da0c154b62802de249b11eabec4c9081f3d2.zip
net-p2p/mktorrent: Version bump to 1.1 with new upstream.
I mailed the old upstream maintainer resp. developer of mktorrent and he confirmed the new maintainer with the repository on github to me. Closes: https://bugs.gentoo.org/621590 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mktorrent/Manifest3
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1.ebuild40
2 files changed, 42 insertions, 1 deletions
diff --git a/net-p2p/mktorrent/Manifest b/net-p2p/mktorrent/Manifest
index 733adc34b81e..6c0db134f6ca 100644
--- a/net-p2p/mktorrent/Manifest
+++ b/net-p2p/mktorrent/Manifest
@@ -1 +1,2 @@
-DIST mktorrent-1.0.tar.gz 23089 SHA256 6f8e562af6366e0d9bde76e434f740b55722c6c3c555860dbe80083f9d1d119f SHA512 f103c8860c008796c2dc604fcabce7374264fd7814237fcad5f9dab0fe10e927b0e2d9b58e7462dd198265a7d83fe30fd68313c7dce4029d8c331a6f2d4622de WHIRLPOOL 2a907fe846ae5a35dbb38fbd6707a89121d34b9658f1afa682db14da9254cc58ed376fc23c834753409769643868294b0f1354fd7d9d567ec0cff49ee713b163
+DIST mktorrent-1.0.tar.gz 23089 BLAKE2B debfdbf2691fd1baa9f1647ef1cd64a4e5d8cbcabd77fb7c8a4b7ec5c1abbf4fa56ae54ea51afc58b0807cde8d525c4ac7106d38576e52a71e2776ba0bfcacda SHA512 f103c8860c008796c2dc604fcabce7374264fd7814237fcad5f9dab0fe10e927b0e2d9b58e7462dd198265a7d83fe30fd68313c7dce4029d8c331a6f2d4622de
+DIST mktorrent-1.1.tar.gz 23314 BLAKE2B 97893553c99f3a6f994876b4689db2536cdaef30f9a392cf3ef800d5d92323336f836a9a3f92aff807a449bcc8553582275c4b36d98e1a1e99835945a7f4b43d SHA512 2a7ce83950711cf5be098693ad79273b29bcd8a5ef345ea296c7b6b83c532dd3463b347c7137234f1890cb4ea663ee5a5b1878591bc8fb4386d94e4f65410859
diff --git a/net-p2p/mktorrent/mktorrent-1.1.ebuild b/net-p2p/mktorrent/mktorrent-1.1.ebuild
new file mode 100644
index 000000000000..75ea9fc65c96
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="https://github.com/Rudde/mktorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Rudde/mktorrent.git"
+else
+ SRC_URI="https://github.com/Rudde/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads +ssl debug"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ emake \
+ USE_LONG_OPTIONS=1 \
+ USE_LARGE_FILES=1 \
+ DEBUG=$(usex debug) \
+ USE_OPENSSL=$(usex ssl) \
+ USE_PTHREADS=$(usex threads)
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}