summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-29 00:09:03 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-29 00:09:03 +0100
commitb2c34e86772c33a88fb514cd82d1f3c56969c91c (patch)
treee97c45f02ec0828274dc4ab43f5776412a85fad6 /net-print/c2esp
parentnet-misc/usbip: Remove old (diff)
downloadgentoo-b2c34e86772c33a88fb514cd82d1f3c56969c91c.tar.gz
gentoo-b2c34e86772c33a88fb514cd82d1f3c56969c91c.tar.bz2
gentoo-b2c34e86772c33a88fb514cd82d1f3c56969c91c.zip
net-print/c2esp: fix build with gcc-10
* Thanks to Sam James for providing the patch link Closes: https://bugs.gentoo.org/708236 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-print/c2esp')
-rw-r--r--net-print/c2esp/c2esp-27.ebuild6
-rw-r--r--net-print/c2esp/files/c2esp-27-fno-common.patch32
-rw-r--r--net-print/c2esp/files/c2esp-27-missing-includes.patch (renamed from net-print/c2esp/files/0001-Fix-various-missing-includes.patch)0
3 files changed, 36 insertions, 2 deletions
diff --git a/net-print/c2esp/c2esp-27.ebuild b/net-print/c2esp/c2esp-27.ebuild
index 69e58fbb92f9..f7fe2a2c6a37 100644
--- a/net-print/c2esp/c2esp-27.ebuild
+++ b/net-print/c2esp/c2esp-27.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,6 +6,7 @@ EAPI=7
DESCRIPTION="A CUPS filter for Kodak ESP printers"
HOMEPAGE="https://sourceforge.net/projects/cupsdriverkodak"
SRC_URI="mirror://sourceforge/cupsdriverkodak/files/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
@@ -17,7 +18,8 @@ DEPEND=">=media-libs/jbigkit-2.0-r1:=
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}"/0001-Fix-various-missing-includes.patch
+ "${FILESDIR}"/${P}-missing-includes.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_configure() {
diff --git a/net-print/c2esp/files/c2esp-27-fno-common.patch b/net-print/c2esp/files/c2esp-27-fno-common.patch
new file mode 100644
index 000000000000..8e4dc81519e2
--- /dev/null
+++ b/net-print/c2esp/files/c2esp-27-fno-common.patch
@@ -0,0 +1,32 @@
+Taken from: https://sources.debian.org/patches/c2esp/27-8/0002-Add-extern-stanzas-to-variable-definitions-in-header.patch/
+Author: Didier Raboud <odyx@debian.org>
+
+--- a/src/c2espcommon.c
++++ b/src/c2espcommon.c
+@@ -42,11 +42,11 @@
+ * Globals...
+ */
+ char CallerName[50]; /* String that identifies the calling program */
+-int DoBack; /* Enables the back channel comms */
++extern int DoBack; /* Enables the back channel comms */
+ char BackBuf[32000]; //for the back channel replies from the printer
+ int BackBufLen=sizeof(BackBuf)-1;
+ FILE *LogFile = NULL; //file descriptor for log file
+-time_t StartTime;
++extern time_t StartTime;
+ int BlackPercent, ColourPercent;
+
+ time_t KeepAwake(time_t Start, int Interval, FILE *PrintFile)
+--- a/src/c2espcommon.h
++++ b/src/c2espcommon.h
+@@ -35,8 +35,8 @@
+ /*
+ * Globals...
+ */
+-char BackBuf[32000]; //for the back channel replies from the printer
+-int ColourPercent, BlackPercent; //to store the detected marker levels
++extern char BackBuf[32000]; //for the back channel replies from the printer
++extern int ColourPercent, BlackPercent; //to store the detected marker levels
+
+
+ time_t KeepAwake(time_t Start, int Interval, FILE *PrintFile);
diff --git a/net-print/c2esp/files/0001-Fix-various-missing-includes.patch b/net-print/c2esp/files/c2esp-27-missing-includes.patch
index bde86e666688..bde86e666688 100644
--- a/net-print/c2esp/files/0001-Fix-various-missing-includes.patch
+++ b/net-print/c2esp/files/c2esp-27-missing-includes.patch