summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-11-09 16:06:17 -0500
committerSam James <sam@gentoo.org>2023-12-18 03:53:21 +0000
commit54a85de9dab134cf17c1fd4def0aa8d003e7a1e8 (patch)
tree65998b88646124ba752b19e0cd039c91394ec6d0 /net-print/cups-filters/cups-filters-2.0.0.ebuild
parentnet-print/libppd: new package, add 2.0.0 (diff)
downloadgentoo-54a85de9dab134cf17c1fd4def0aa8d003e7a1e8.tar.gz
gentoo-54a85de9dab134cf17c1fd4def0aa8d003e7a1e8.tar.bz2
gentoo-54a85de9dab134cf17c1fd4def0aa8d003e7a1e8.zip
net-print/cups-filters: add 2.0.0
Part of the CUPS v3 evolution. Now, cups-filters has been split out into multiple sub-packages. The new version of cups-filters depends on a couple of extracted libraries, and builds on these to distribute the actual filters. It no longer handles browsed at all -- this is a completely separate, optional component. Most options are no longer relevant, as they are encapsulated in the subpackages. Closes: https://bugs.gentoo.org/914586 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print/cups-filters/cups-filters-2.0.0.ebuild')
-rw-r--r--net-print/cups-filters/cups-filters-2.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-print/cups-filters/cups-filters-2.0.0.ebuild b/net-print/cups-filters/cups-filters-2.0.0.ebuild
new file mode 100644
index 000000000000..fde6177f0322
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+SRC_URI="https://github.com/OpenPrinting/cups-filters/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+foomatic"
+#IUSE=""
+KEYWORDS="~amd64"
+
+RDEPEND="
+ net-print/libcupsfilters
+ net-print/libppd
+ >=net-print/cups-1.7.3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-imagefilters
+ --enable-driverless
+ --enable-poppler
+ --localstatedir="${EPREFIX}"/var
+ --with-fontdir="fonts/conf.avail"
+ # cups-browsed is split out and avahi is not needed for filters
+ # https://github.com/OpenPrinting/cups-filters/pull/558
+ --disable-avahi
+ # These are just probed for the path. Always enable them.
+ --with-gs-path="${EPREFIX}"/usr/bin/gs
+ --with-mutool-path="${EPREFIX}"/usr/bin/mutool
+
+ $(use_enable foomatic)
+ )
+
+ econf "${myeconfargs[@]}"
+}