summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-03 18:34:56 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-03 18:35:06 +0100
commitbd043883324a47e3a02b4174fbcc13b3eebd7c15 (patch)
treee005a509e026842c9d3d5f9b7aeaa95ecead38df /net-print/cups-filters
parentnet-misc/dhcpcd: Removed 8.1.4 by upstream request (diff)
downloadgentoo-bd043883324a47e3a02b4174fbcc13b3eebd7c15.tar.gz
gentoo-bd043883324a47e3a02b4174fbcc13b3eebd7c15.tar.bz2
gentoo-bd043883324a47e3a02b4174fbcc13b3eebd7c15.zip
net-print/cups-filters: Bump to version 1.26.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-print/cups-filters')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.26.1.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index 8076bf739273..538f094924d3 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -1,3 +1,4 @@
DIST cups-filters-1.25.11.tar.xz 1482792 BLAKE2B 67801904dbe025933d1209817e23ff74b661b35c3af560081f12d4f9a26102e009bac9d4741e15dc257dd477967b18ae23911647f8f56b361e9f8d51b0d619f2 SHA512 67e7c624952b5e2db33a698ac1287a3448a4787fa28000cefc5a982c2fa18a4f56e11e3ba65da8a6e565a53a193c6eb31ba1867ad36ca8dc7e61250f11232681
DIST cups-filters-1.25.13.tar.xz 1485860 BLAKE2B 03fbbbefdd36e8f619fabf17e6e13d051f48f68f87260747a181f6976ff88728d7d01b646227cd5f054e0321f6fe0e64e4c6b1bdba631d9d703304ad98a625eb SHA512 4b5ef647870235436276db68f3ef1879b578807338a025100a1d43115a7330a8f506be631df9c43edb2f1ec15f9a42f15f7cdc725bb5d39612b37bae04631611
DIST cups-filters-1.26.0.tar.xz 1489308 BLAKE2B 4a0c67f9dba60c409cd62c3f47e167b79be01fd53c51d08c368e62919020d9f1ebe72ebd570e773537053ae4cc42846f426c166675faa0a18392afdb1d66c284 SHA512 a6e0a1b8dfec2e46cb2475639b33f60da3a74090718334883564711530e13c7524952b9f145303c1063e1ae21eb585dce1fd9c87e4ce7884ec687fdef58f2124
+DIST cups-filters-1.26.1.tar.xz 1489804 BLAKE2B 8a5b18cdd192b2847889b4a5ab865152653b443ea01246b52a12fc20b022d6d0d09187cb9c2483d684452a8d7308ae60cb8217efe3e2e13de5001f43b727fe8d SHA512 0aaad7ceeb763aa3da4f961c99f85c0200cf4fcd071617506daf97dad4914de38fa744ae692b6fbc1d00a0eec62b4de4d7c5f865fd0e32e4155ab3f0c5a21ede
diff --git a/net-print/cups-filters/cups-filters-1.26.1.ebuild b/net-print/cups-filters/cups-filters-1.26.1.ebuild
new file mode 100644
index 000000000000..7d3a3240e736
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.26.1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+ >=app-text/qpdf-8.3.0:=
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ ldap? ( net-nds/openldap )
+ pdf? ( app-text/mupdf )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+ default
+ [[ "${PV}" == "9999" ]] && eautoreconf
+
+ # Bug #626800
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-imagefilters
+ --localstatedir="${EPREFIX}"/var
+ --with-browseremoteprotocols=DNSSD,CUPS
+ --with-cups-rundir="${EPREFIX}"/run/cups
+ --with-fontdir="fonts/conf.avail"
+ --with-pdftops=pdftops
+ --with-rcdir=no
+ --without-php
+ $(use_enable dbus)
+ $(use_enable foomatic)
+ $(use_enable ipp_autosetup auto-setup-driverless)
+ $(use_enable ldap)
+ $(use_enable pclm)
+ $(use_enable pdf mutool)
+ $(use_enable postscript ghostscript)
+ $(use_enable static-libs static)
+ $(use_enable zeroconf avahi)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null
+ fi
+
+ if use postscript; then
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym gstopxl /usr/libexec/cups/filter/pstopxl
+ fi
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+ emake check
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}