summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-08-16 12:30:58 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-08-16 12:30:58 +0200
commitf490b147fd109ba8454f61b9dffe7fc48661c0a0 (patch)
tree73a20d3dab4bea132abbb1d3bc2af137a8f78fcb /net-print/hplip-plugin
parentapp-portage/eix: Version bump to 0.31.8 (diff)
downloadgentoo-f490b147fd109ba8454f61b9dffe7fc48661c0a0.tar.gz
gentoo-f490b147fd109ba8454f61b9dffe7fc48661c0a0.tar.bz2
gentoo-f490b147fd109ba8454f61b9dffe7fc48661c0a0.zip
net-print/hplip-plugin: Version bump to 3.16.7
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.16.7.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 0cf9c243be2d..ed94dfa99731 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,4 @@
DIST hplip-3.14.10-plugin.run 1869038 SHA256 b395b480ad86b9f27b6a2f63b6ecb00beb78e762a6137efb81dc1104837f9b81 SHA512 3e5bea924e989d902aea0de182941be692a124ba8c27f53ce2e4f137308bad8373462c6128c26716e481e758f76533163d311a2676df034c1b15d6ef6ed008be WHIRLPOOL 18375de4cc92cb73bcaa109927bd34f8487938b02472f0b7adbf44ad4688e5c6a1d030077b1e3c14f15f9b8e4cc86d195b0195e2d08121f746c62624db4658db
DIST hplip-3.16.3-plugin.run 2084271 SHA256 b7edef2a1c5c0a5e001deb4a18c0ef7202e653596e97144b8908ae093818070f SHA512 2ae8aeb40c2604a2c6b9725700f9addf7a82e819d603631158a5d5feac931248e53e7533178100df1fc12b0dc2340cb3ae0d85f145cd023a311f77bbe67e7c7f WHIRLPOOL 928117f862030eca9c3e5813eb8c4db66570923695b0c7af17df1992f339d2478f42af67ca0e0eb8cfa1d7425b522082fde3b8c829c3f5167e1ec503c95a986b
DIST hplip-3.16.5-plugin.run 2084359 SHA256 783c74b301a1ea25cdd1f079805e9cee0f27b697babae6ae89b9db6647631997 SHA512 2a49fed0a89e8ba987d58b5c681cd2cfbdb4d235ce2ae4c9a943c763cdb1038a754075f7b65e857c8d21f64a3f7b440abe04d15ca1faf46f3709581aae4ff6fe WHIRLPOOL c7b72fe33e212581dd3c9fdd7bf9b77a204856479a9cfd5b960869f6882728037f48cbc2a3df7c103dc876fb16b922923733af8955588279ad7606f47e564fd5
+DIST hplip-3.16.7-plugin.run 2084352 SHA256 6e0818ec4581a814c0d92dce953ecf85eb7b9b10d358a3c9e8282162591e88cc SHA512 5b361c13e2b0efa59877897c1fc034d3a75194e0d39571c7e850c11544d7c85931852b3c4dea6945378793b529ffa3704377f81cab8b04fcc2abf0dee41d1b05 WHIRLPOOL 47a93d599644761a90ef6a5bfb51532fc7ecd76421ab14c5bba7bb7b29bbc0e73fceb0400c47a3ca7d13134a1aefb4bbd74d1fc8a353a0b39379fa113d53fbb1
diff --git a/net-print/hplip-plugin/hplip-plugin-3.16.7.ebuild b/net-print/hplip-plugin/hplip-plugin-3.16.7.ebuild
new file mode 100644
index 000000000000..8408448871b0
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.16.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}