summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 14:10:40 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 14:17:01 -0500
commitd223f92871a17247bb411f4183ef11e127ecf62b (patch)
tree745ad0492187b6293aac13598e498c752d4b45a8 /net-proxy
parentnet-proxy/tinyproxy: use #!/sbin/openrc-run instead of #!/sbin/runscript (diff)
downloadgentoo-d223f92871a17247bb411f4183ef11e127ecf62b.tar.gz
gentoo-d223f92871a17247bb411f4183ef11e127ecf62b.tar.bz2
gentoo-d223f92871a17247bb411f4183ef11e127ecf62b.zip
net-proxy/tinyproxy: remove old version
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.8.3-r3.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/net-proxy/tinyproxy/tinyproxy-1.8.3-r3.ebuild b/net-proxy/tinyproxy/tinyproxy-1.8.3-r3.ebuild
deleted file mode 100644
index f31cf7d3f297..000000000000
--- a/net-proxy/tinyproxy/tinyproxy-1.8.3-r3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit autotools eutils systemd user
-
-DESCRIPTION="A lightweight HTTP/SSL proxy"
-HOMEPAGE="http://www.banu.com/tinyproxy/"
-SRC_URI="http://www.banu.com/pub/${PN}/1.8/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ia64 ppc sparc x86"
-
-IUSE="test debug +filter-proxy minimal reverse-proxy
- transparent-proxy +upstream-proxy +xtinyproxy-header"
-
-REQUIRED_USE="test? ( xtinyproxy-header )"
-
-DEPEND="!minimal? ( app-text/asciidoc )"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} "" "" "" ${PN}
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.1-ldflags.patch
- epatch "${FILESDIR}"/${P}-r2-DoS-Prevention.patch
-
- use minimal && epatch "${FILESDIR}/${PN}-1.8.1-minimal.patch"
-
- sed -i \
- -e "s|nobody|${PN}|g" \
- -e 's|/var/run/|/run/|g' \
- etc/${PN}.conf.in || die "sed failed"
-
- sed -i \
- -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
- configure.ac || die
-
- eautoreconf
-}
-
-src_configure() {
- if use minimal; then
- ln -s /bin/true "${T}"/a2x
- export PATH="${T}:${PATH}"
- fi
-
- econf \
- $(use_enable debug) \
- $(use_enable filter-proxy filter) \
- $(use_enable reverse-proxy reverse) \
- $(use_enable transparent-proxy transparent) \
- $(use_enable upstream-proxy upstream) \
- $(use_enable xtinyproxy-header xtinyproxy) \
- --disable-silent-rules \
- --localstatedir=/var
-}
-
-src_test() {
- # The make check target does not run the test suite
- emake test
-}
-
-src_install() {
- default
-
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- diropts -m0775 -o ${PN} -g ${PN}
- keepdir /var/log/${PN}
-
- newinitd "${FILESDIR}"/${PN}-1.8.3-r2.initd tinyproxy
- systemd_dounit "${FILESDIR}"/${PN}.service
- systemd_dotmpfilesd "${FILESDIR}"/${PN}.tmpfiles.conf
-}
-
-pkg_postinst() {
- elog "For filtering domains and URLs, enable filter option in the configuration"
- elog "file and add them to the filter file (one domain or URL per line)."
-}