summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-12-29 15:58:51 +0200
committerSam James <sam@gentoo.org>2021-01-04 16:32:48 +0000
commit05d9dc2f59a21408b09c228c5ab58555519c89c7 (patch)
tree6222cd656ca5962f9725ee3c3848a7ffdf8f20f8 /net-voip/yate/yate-6.1.0.ebuild
parentnet-voip/yate: bring -9999 in line with 6.2.0. (diff)
downloadgentoo-05d9dc2f59a21408b09c228c5ab58555519c89c7.tar.gz
gentoo-05d9dc2f59a21408b09c228c5ab58555519c89c7.tar.bz2
gentoo-05d9dc2f59a21408b09c228c5ab58555519c89c7.zip
net-voip/yate: Cleanup.
Remove older versions blocking removal of dev-libs/ilbc-rfc3951. Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-voip/yate/yate-6.1.0.ebuild')
-rw-r--r--net-voip/yate/yate-6.1.0.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/net-voip/yate/yate-6.1.0.ebuild b/net-voip/yate/yate-6.1.0.ebuild
deleted file mode 100644
index b44cc916db18..000000000000
--- a/net-voip/yate/yate-6.1.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="The Yate AV Suite"
-HOMEPAGE="http://yate.null.ro/"
-
-if [[ ${PV} == 9999 ]] ; then
- ESVN_REPO_URI="http://voip.null.ro/svn/yate/trunk"
- inherit subversion
- KEYWORDS=""
-else
- SRC_URI="http://voip.null.ro/tarballs/${PN}6/${P}-1.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
- S="${WORKDIR}/${PN}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex spandsp +ssl +zlib amrnb"
-
-RDEPEND="
- postgres? ( dev-db/postgresql:* )
- mysql? ( virtual/mysql )
- gsm? ( media-sound/gsm )
- speex? ( media-libs/speex )
- ssl? ( dev-libs/openssl:0 )
- zlib? ( sys-libs/zlib )
- ilbc? ( dev-libs/ilbc-rfc3951 )
- spandsp? ( >=media-libs/spandsp-0.0.3 )
- dahdi? ( net-misc/dahdi )
-"
-DEPEND="doc? ( app-doc/doxygen )
- virtual/pkgconfig
- ${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-6.0.0-dont-mess-with-cflags.patch )
-
-src_prepare() {
- default_src_prepare
- eautoreconf
- ./yate-config.sh || die
-}
-
-#fdsize, inline, rtti: keep default values
-#internalregex: use system
-#coredumper: not in the tree, bug 118716
-#wanpipe, wphwec: not in the tree, bug 188939
-#amrnb: not in tree!
-#zaptel: ??
-src_configure() {
- econf \
- --with-archlib=$(get_libdir) \
- --without-libqt4 \
- $(use_enable cpu_flags_x86_sse2 sse2) \
- $(use_enable sctp) \
- $(use_enable dahdi) \
- $(use_enable zaptel) \
- $(use_enable wpcard) \
- $(use_enable tdmcard) \
- $(use_enable wanpipe) \
- $(use_enable ilbc) \
- $(use_enable ilbc-webrtc) \
- $(use_enable isac-float) \
- $(use_enable isac-fixed) \
- $(use_with postgres libpq) \
- $(use_with mysql) \
- $(use_with gsm libgsm) \
- $(use_with speex libspeex) \
- $(use_with amrnb) \
- $(use_with spandsp) \
- $(use_with ssl openssl)
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- if use doc; then
- emake DESTDIR="${ED}" install
- else
- emake DESTDIR="${ED}" install-noapi
- fi
- newinitd "${FILESDIR}"/yate.initd yate
- newconfd "${FILESDIR}"/yate.confd yate
-}