summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-voip/yate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-voip/yate')
-rw-r--r--net-voip/yate/Manifest1
-rw-r--r--net-voip/yate/files/dont-mess-with-cflags.patch15
-rw-r--r--net-voip/yate/files/yate.confd10
-rw-r--r--net-voip/yate/files/yate.initd34
-rwxr-xr-xnet-voip/yate/files/yate.rc620
-rw-r--r--net-voip/yate/metadata.xml25
-rw-r--r--net-voip/yate/yate-5.4.0.ebuild91
-rw-r--r--net-voip/yate/yate-9999.ebuild90
8 files changed, 286 insertions, 0 deletions
diff --git a/net-voip/yate/Manifest b/net-voip/yate/Manifest
new file mode 100644
index 000000000000..d2dd6f4df04d
--- /dev/null
+++ b/net-voip/yate/Manifest
@@ -0,0 +1 @@
+DIST yate-5.4.0-1.tar.gz 5027248 SHA256 4705af7b4c110de11b0cee70e37f9815d130082a4c49b3f093cae07c79539344 SHA512 27c4bb7b00c37a9eaff7be210ba0812a0267fb186b357186734115ded73627dbf8fd3f292a3efbf7b33ca3e7c2e6a6f460d0ee4068e2a8415c58e3f698ae5e5b WHIRLPOOL 5a1243321044d25d134e47ef99cf6be9c2e51badb4c75d4952a3b5727c5aad8228f9a184d0ee66394ec928945b60bf80c5505696675b9666a61d46d2b7787d65
diff --git a/net-voip/yate/files/dont-mess-with-cflags.patch b/net-voip/yate/files/dont-mess-with-cflags.patch
new file mode 100644
index 000000000000..961d73fa1ccc
--- /dev/null
+++ b/net-voip/yate/files/dont-mess-with-cflags.patch
@@ -0,0 +1,15 @@
+https://build.opensuse.org/package/view_file/network:telephony/yate/dont-mess-with-cflags.patch?expand=1
+
+Index: yate/configure.in
+===================================================================
+--- yate.orig/configure.in
++++ yate/configure.in
+@@ -1447,7 +1447,6 @@ fi
+
+
+ INSTALL_D="install -D"
+-CFLAGS=`echo "$CFLAGS" | sed 's/\(^\| *\)-g[[0-9]]*//' | sed 's/[[[:space:]]]\{2,\}/ /g'`
+ MODULE_CFLAGS="-fno-exceptions -fPIC $HAVE_GCC_FORMAT_CHECK $HAVE_BLOCK_RETURN"
+ MODULE_CPPFLAGS="-fno-check-new $RTTI_OPT $MODULE_CFLAGS"
+ MODULE_LDRELAX="-export-dynamic -shared"
+
diff --git a/net-voip/yate/files/yate.confd b/net-voip/yate/files/yate.confd
new file mode 100644
index 000000000000..926cc563919f
--- /dev/null
+++ b/net-voip/yate/files/yate.confd
@@ -0,0 +1,10 @@
+# /etc/conf.d/yate: config file for /etc/init.d/yate
+
+# Any random options you want to pass to yate
+YATE_OPTS=""
+
+# Pid file to use (needs to be absolute path)
+#YATE_PIDFILE="/var/run/yate.pid"
+
+# Path to yate binary (needs to be absolute path)
+#YATE_BINARY="/usr/bin/yate"
diff --git a/net-voip/yate/files/yate.initd b/net-voip/yate/files/yate.initd
new file mode 100644
index 000000000000..01f07f4a538d
--- /dev/null
+++ b/net-voip/yate/files/yate.initd
@@ -0,0 +1,34 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+opts="${opts} reload"
+
+YATE_PIDFILE=${YATE_PIDFILE:-/var/run/${SVCNAME}.pid}
+YATE_BINARY=${YATE_BINARY:-/usr/bin/yate}
+
+depend() {
+ need net
+ use mysql postgresql zaptel
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec "${YATE_BINARY}" \
+ -- -d -p "${YATE_PIDFILE}" ${YATE_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile="${YATE_PIDFILE}"
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --stop --exec "${YATE_BINARY}" \
+ --pidfile "${YATE_PIDFILE}" --signal HUP --oknodo
+ eend $?
+}
diff --git a/net-voip/yate/files/yate.rc6 b/net-voip/yate/files/yate.rc6
new file mode 100755
index 000000000000..d2d8a5adac0d
--- /dev/null
+++ b/net-voip/yate/files/yate.rc6
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting YATE"
+ start-stop-daemon --start --exec /usr/bin/yate -- -d -p /var/run/yate.pid ${YATE_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping YATE"
+ start-stop-daemon --stop --pidfile=/var/run/yate.pid
+ eend $?
+}
diff --git a/net-voip/yate/metadata.xml b/net-voip/yate/metadata.xml
new file mode 100644
index 000000000000..58e94f3d0099
--- /dev/null
+++ b/net-voip/yate/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>radio</herd>
+ <use>
+ <flag name="sctp">Enable SCTP sockets</flag>
+ <flag name="dahdi">Enable Dahdi driver</flag>
+ <flag name="zaptel">Enable Zaptel driver</flag>
+ <flag name="wpcard">Enable Wanpipe card driver</flag>
+ <flag name="tdmcard">Enable TDMV API card driver</flag>
+ <flag name="wanpipe">Enable Wanpipe support</flag>
+ <flag name="ilbc">Enable iLBC codec</flag>
+ <flag name="ilbc-webrtc">Enable iLBC webrtc codec</flag>
+ <flag name="isac-float">Enable iSAC float codec</flag>
+ <flag name="isac-fixed">Enable iSAC fixed codec</flag>
+ <flag name="postgres">use Postgress SQL</flag>
+ <flag name="mysql">use MySQL client library</flag>
+ <flag name="gsm">use GSM codec</flag>
+ <flag name="speex">use Speex codec</flag>
+ <flag name="amrnb">use AMR-NB</flag>
+ <flag name="spandsp">use spandsp library</flag>
+ <flag name="h323">use OpenH323</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/net-voip/yate/yate-5.4.0.ebuild b/net-voip/yate/yate-5.4.0.ebuild
new file mode 100644
index 000000000000..fe04d7220062
--- /dev/null
+++ b/net-voip/yate/yate-5.4.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="The Yate AV Suite"
+HOMEPAGE="http://yate.null.ro/"
+
+if [[ ${PV} == 9999 ]] ; then
+ ESVN_REPO_URI="http://voip.null.ro/svn/yate/trunk"
+ inherit subversion
+ KEYWORDS=""
+else
+ SRC_URI="http://voip.null.ro/tarballs/${PN}5/${P}-1.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex h323 spandsp +ssl qt4 +zlib amrnb"
+
+RDEPEND="
+ postgres? ( dev-db/postgresql )
+ mysql? ( virtual/mysql )
+ gsm? ( media-sound/gsm )
+ speex? ( media-libs/speex )
+ ssl? ( dev-libs/openssl )
+ h323? ( net-libs/h323plus )
+ zlib? ( sys-libs/zlib )
+ qt4? ( dev-qt/qtgui:4 dev-qt/designer:4 )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ spandsp? ( >=media-libs/spandsp-0.0.3 )
+ dahdi? ( net-misc/dahdi )
+"
+DEPEND="doc? ( || ( app-doc/doxygen dev-util/kdoc ) )
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/dont-mess-with-cflags.patch
+ eautoreconf
+ ./yate-config.sh || die
+}
+
+#fdsize, inline, rtti: keep default values
+#internalregex: use system
+#coredumper: not in the tree, bug 118716
+#wanpipe, wphwec: not in the tree, bug 188939
+#amrnb: not in tree!
+#zaptel: ??
+src_configure() {
+ econf \
+ --with-archlib=$(get_libdir) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable sctp) \
+ $(use_enable dahdi) \
+ $(use_enable zaptel) \
+ $(use_enable wpcard) \
+ $(use_enable tdmcard) \
+ $(use_enable wanpipe) \
+ $(use_enable ilbc) \
+ $(use_enable ilbc-webrtc) \
+ $(use_enable isac-float) \
+ $(use_enable isac-fixed) \
+ $(use_with postgres libpq) \
+ $(use_with mysql) \
+ $(use_with gsm libgsm) \
+ $(use_with speex libspeex) \
+ $(use_with amrnb) \
+ $(use_with spandsp) \
+ $(use_with h323 openh323 /usr) \
+ $(use_with h323 pwlib /usr) \
+ $(use_with ssl openssl) \
+ $(use_with qt4 libqt4)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${ED}" install
+ else
+ emake DESTDIR="${ED}" install-noapi
+ fi
+}
diff --git a/net-voip/yate/yate-9999.ebuild b/net-voip/yate/yate-9999.ebuild
new file mode 100644
index 000000000000..a09f6b3ed8e9
--- /dev/null
+++ b/net-voip/yate/yate-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="The Yate AV Suite"
+HOMEPAGE="http://yate.null.ro/"
+
+if [[ ${PV} == 9999 ]] ; then
+ ESVN_REPO_URI="http://voip.null.ro/svn/yate/trunk"
+ inherit subversion
+ KEYWORDS=""
+else
+ SRC_URI="http://voip.null.ro/tarballs/${PN}5/${P}-1.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex h323 spandsp +ssl qt4 +zlib amrnb"
+
+RDEPEND="
+ postgres? ( dev-db/postgresql )
+ mysql? ( virtual/mysql )
+ gsm? ( media-sound/gsm )
+ speex? ( media-libs/speex )
+ ssl? ( dev-libs/openssl )
+ h323? ( net-libs/h323plus )
+ zlib? ( sys-libs/zlib )
+ qt4? ( dev-qt/qtgui:4 dev-qt/designer:4 )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ spandsp? ( >=media-libs/spandsp-0.0.3 )
+ dahdi? ( net-misc/dahdi )
+"
+DEPEND="doc? ( || ( app-doc/doxygen dev-util/kdoc ) )
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ ./yate-config.sh || die
+}
+
+#fdsize, inline, rtti: keep default values
+#internalregex: use system
+#coredumper: not in the tree, bug 118716
+#wanpipe, wphwec: not in the tree, bug 188939
+#amrnb: not in tree!
+#zaptel: ??
+src_configure() {
+ econf \
+ --with-archlib=$(get_libdir) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable sctp) \
+ $(use_enable dahdi) \
+ $(use_enable zaptel) \
+ $(use_enable wpcard) \
+ $(use_enable tdmcard) \
+ $(use_enable wanpipe) \
+ $(use_enable ilbc) \
+ $(use_enable ilbc-webrtc) \
+ $(use_enable isac-float) \
+ $(use_enable isac-fixed) \
+ $(use_with postgres libpq) \
+ $(use_with mysql) \
+ $(use_with gsm libgsm) \
+ $(use_with speex libspeex) \
+ $(use_with amrnb) \
+ $(use_with spandsp) \
+ $(use_with h323 openh323 /usr) \
+ $(use_with h323 pwlib /usr) \
+ $(use_with ssl openssl) \
+ $(use_with qt4 libqt4)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${ED}" install
+ else
+ emake DESTDIR="${ED}" install-noapi
+ fi
+}