summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitrii Tochanskii <tochansky@tochlab.net>2021-05-22 13:23:33 +0300
committerSam James <sam@gentoo.org>2021-07-25 04:32:02 +0100
commit4a43031d7e76be66e1a94059dbe1eefcdb1efdcd (patch)
treed5a8ed6131b4ea11123ccfb4e4d0cd91f7fcc748 /net-vpn/networkmanager-l2tp
parentdev-python/tomli: Keyword 1.0.4 arm, #802543 (diff)
downloadgentoo-4a43031d7e76be66e1a94059dbe1eefcdb1efdcd.tar.gz
gentoo-4a43031d7e76be66e1a94059dbe1eefcdb1efdcd.tar.bz2
gentoo-4a43031d7e76be66e1a94059dbe1eefcdb1efdcd.zip
net-vpn/networkmanager-l2tp: use correct ppp plugin path
By default /usr/lib64/pppd/2.4.7/ path used. This will use right path from portage. Bug: https://bugs.gentoo.org/722718 Closes: https://github.com/gentoo/gentoo/pull/20926 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/networkmanager-l2tp')
-rw-r--r--net-vpn/networkmanager-l2tp/networkmanager-l2tp-1.8.2-r1.ebuild (renamed from net-vpn/networkmanager-l2tp/networkmanager-l2tp-1.8.2.ebuild)11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-vpn/networkmanager-l2tp/networkmanager-l2tp-1.8.2.ebuild b/net-vpn/networkmanager-l2tp/networkmanager-l2tp-1.8.2-r1.ebuild
index ec5ca2a6dde..0db9addd396 100644
--- a/net-vpn/networkmanager-l2tp/networkmanager-l2tp-1.8.2.ebuild
+++ b/net-vpn/networkmanager-l2tp/networkmanager-l2tp-1.8.2-r1.ebuild
@@ -20,7 +20,7 @@ IUSE="gnome static-libs"
RDEPEND="
>=net-misc/networkmanager-1.2[ppp]
dev-libs/dbus-glib
- net-dialup/ppp[eap-tls]
+ net-dialup/ppp:=[eap-tls]
net-dialup/xl2tpd
>=dev-libs/glib-2.32
|| (
@@ -32,8 +32,8 @@ RDEPEND="
app-crypt/libsecret
gnome-extra/nm-applet
)"
-
-BDEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/gettext
dev-util/intltool
virtual/pkgconfig"
@@ -46,8 +46,13 @@ src_prepare() {
}
src_configure() {
+ local PPPD_VER=$(best_version net-dialup/ppp)
+ PPPD_VER=${PPPD_VER#*/*-} # reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+
local myeconfargs=(
--localstatedir=/var
+ --with-pppd-plugin-dir=/usr/$(get_libdir)/pppd/${PPPD_VER}
$(use_with gnome)
$(use_enable static-libs static)
)