summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2019-12-26 17:46:23 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2019-12-26 17:47:16 +0100
commit38dbe9e8af0e04193eece8172105b75ffdac8f34 (patch)
tree7ae15e5c6e3601432e74fdd64dfcf9b2714d5726 /net-vpn/wireguard
parentnet-vpn/wireguard-tools: add missing info from monolithic ebuild (diff)
downloadgentoo-38dbe9e8af0e04193eece8172105b75ffdac8f34.tar.gz
gentoo-38dbe9e8af0e04193eece8172105b75ffdac8f34.tar.bz2
gentoo-38dbe9e8af0e04193eece8172105b75ffdac8f34.zip
net-vpn/wireguard: revbump in preparation for move to virtual
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'net-vpn/wireguard')
-rw-r--r--net-vpn/wireguard/Manifest1
-rw-r--r--net-vpn/wireguard/wireguard-0.0.20191219-r1.ebuild137
-rw-r--r--net-vpn/wireguard/wireguard-0.0.20191219-r2.ebuild19
-rw-r--r--net-vpn/wireguard/wireguard-9999.ebuild137
4 files changed, 19 insertions, 275 deletions
diff --git a/net-vpn/wireguard/Manifest b/net-vpn/wireguard/Manifest
deleted file mode 100644
index e795e99cfef3..000000000000
--- a/net-vpn/wireguard/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST WireGuard-0.0.20191219.tar.xz 332596 BLAKE2B d670a762ec230138ba2889e2156c65d37630df9f368bde4eb619960333d91739ffed72a040cc762aa964ed137d6cde8761e1838c1a561dbe0aa5451333f4eb52 SHA512 0ff9f50e36378b2444f1cd670138e58676cee04f82dcc637d47aea69268034c950103609f7e35af14d7d1b0b579535000330737c2071f61b2d56147c95ef8e71
diff --git a/net-vpn/wireguard/wireguard-0.0.20191219-r1.ebuild b/net-vpn/wireguard/wireguard-0.0.20191219-r1.ebuild
deleted file mode 100644
index 917e43d3e740..000000000000
--- a/net-vpn/wireguard/wireguard-0.0.20191219-r1.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MODULES_OPTIONAL_USE="module"
-inherit linux-mod bash-completion-r1
-
-DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
-HOMEPAGE="https://www.wireguard.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.zx2c4.com/WireGuard"
- KEYWORDS=""
-else
- SRC_URI="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-${PV}.tar.xz"
- S="${WORKDIR}/WireGuard-${PV}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug +module +tools module-src"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- tools? ( net-vpn/wireguard-tools )
-"
-
-MODULE_NAMES="wireguard(kernel/drivers/net:src)"
-BUILD_TARGETS="module"
-CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
-
-wg_quick_optional_config_nob() {
- CONFIG_CHECK="$CONFIG_CHECK ~$1"
- declare -g ERROR_$1="CONFIG_$1: This option is required for automatic routing of default routes inside of wg-quick(8), though it is not required for general WireGuard usage."
-}
-
-pkg_setup() {
- if use module; then
- if use tools; then
- wg_quick_optional_config_nob IP_ADVANCED_ROUTER
- wg_quick_optional_config_nob IP_MULTIPLE_TABLES
- wg_quick_optional_config_nob NETFILTER_XT_MARK
- wg_quick_optional_config_nob NETFILTER_XT_CONNMARK
- wg_quick_optional_config_nob IP6_NF_RAW
- wg_quick_optional_config_nob IP_NF_RAW
- fi
-
- linux-mod_pkg_setup
- kernel_is -lt 3 10 0 && die "This version of ${PN} requires Linux >= 3.10"
- fi
-}
-
-src_compile() {
- BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
- use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
- use module && linux-mod_src_compile
-}
-
-src_install() {
- use module && linux-mod_src_install
- use module-src && emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src dkms-install
-}
-
-pkg_postinst() {
- if use module-src && ! use module; then
- einfo
- einfo "You have enabled the module-src USE flag without the module USE"
- einfo "flag. This means that sources are installed to"
- einfo "${ROOT}usr/src/wireguard instead of having the"
- einfo "kernel module compiled. You will need to compile the module"
- einfo "yourself. Most likely, you don't want this USE flag, and should"
- einfo "rather use USE=module"
- einfo
- fi
- use module && linux-mod_pkg_postinst
-
- einfo
- einfo "This software is experimental and has not yet been released."
- einfo "As such, it may contain significant issues. Please do not file"
- einfo "bug reports with Gentoo, but rather direct them upstream to:"
- einfo
- einfo " team@wireguard.com security@wireguard.com"
- einfo
-
- if use tools; then
- einfo
- einfo "After installing WireGuard, if you'd like to try sending some packets through"
- einfo "WireGuard, you may use, for testing purposes only, the insecure client.sh"
- einfo "test example script:"
- einfo
- einfo " \$ bzcat ${ROOT}usr/share/doc/${PF}/examples/ncat-client-server/client.sh.bz2 | sudo bash -"
- einfo
- einfo "This will automatically setup interface wg0, through a very insecure transport"
- einfo "that is only suitable for demonstration purposes. You can then try loading the"
- einfo "hidden website or sending pings:"
- einfo
- einfo " \$ chromium http://192.168.4.1"
- einfo " \$ ping 192.168.4.1"
- einfo
- einfo "If you'd like to redirect your internet traffic, you can run it with the"
- einfo "\"default-route\" argument. You may not use this server for any abusive or illegal"
- einfo "purposes. It is for quick testing only."
- einfo
- einfo "More info on getting started can be found at: https://www.wireguard.com/quickstart/"
- einfo
- fi
- if use module; then
- local old new
- if [[ $(uname -r) != "${KV_FULL}" ]]; then
- ewarn
- ewarn "You have just built WireGuard for kernel ${KV_FULL}, yet the currently running"
- ewarn "kernel is $(uname -r). If you intend to use this WireGuard module on the currently"
- ewarn "running machine, you will first need to reboot it into the kernel ${KV_FULL}, for"
- ewarn "which this module was built."
- ewarn
- elif [[ -f /sys/module/wireguard/version ]] && \
- old="$(< /sys/module/wireguard/version)" && \
- new="$(modinfo -F version "${ROOT}/lib/modules/${KV_FULL}/net/wireguard.ko" 2>/dev/null)" && \
- [[ $old != "$new" ]]; then
- ewarn
- ewarn "You appear to have just upgraded WireGuard from version v$old to v$new."
- ewarn "However, the old version is still running on your system. In order to use the"
- ewarn "new version, you will need to remove the old module and load the new one. As"
- ewarn "root, you can accomplish this with the following commands:"
- ewarn
- ewarn " # rmmod wireguard"
- ewarn " # modprobe wireguard"
- ewarn
- ewarn "Do note that doing this will remove current WireGuard interfaces, so you may want"
- ewarn "to gracefully remove them yourself prior."
- ewarn
- fi
- fi
-}
diff --git a/net-vpn/wireguard/wireguard-0.0.20191219-r2.ebuild b/net-vpn/wireguard/wireguard-0.0.20191219-r2.ebuild
new file mode 100644
index 000000000000..bd9e9772ed80
--- /dev/null
+++ b/net-vpn/wireguard/wireguard-0.0.20191219-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
+HOMEPAGE="https://www.wireguard.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug +module +tools module-src"
+
+RDEPEND="
+ tools? ( net-vpn/wireguard-tools )
+ module? ( net-vpn/wireguard-modules[module] )
+ module-src? ( net-vpn/wireguard-modules[module-src] )
+ debug? ( net-vpn/wireguard-modules[debug] )
+"
diff --git a/net-vpn/wireguard/wireguard-9999.ebuild b/net-vpn/wireguard/wireguard-9999.ebuild
deleted file mode 100644
index 917e43d3e740..000000000000
--- a/net-vpn/wireguard/wireguard-9999.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MODULES_OPTIONAL_USE="module"
-inherit linux-mod bash-completion-r1
-
-DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
-HOMEPAGE="https://www.wireguard.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.zx2c4.com/WireGuard"
- KEYWORDS=""
-else
- SRC_URI="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-${PV}.tar.xz"
- S="${WORKDIR}/WireGuard-${PV}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug +module +tools module-src"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- tools? ( net-vpn/wireguard-tools )
-"
-
-MODULE_NAMES="wireguard(kernel/drivers/net:src)"
-BUILD_TARGETS="module"
-CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
-
-wg_quick_optional_config_nob() {
- CONFIG_CHECK="$CONFIG_CHECK ~$1"
- declare -g ERROR_$1="CONFIG_$1: This option is required for automatic routing of default routes inside of wg-quick(8), though it is not required for general WireGuard usage."
-}
-
-pkg_setup() {
- if use module; then
- if use tools; then
- wg_quick_optional_config_nob IP_ADVANCED_ROUTER
- wg_quick_optional_config_nob IP_MULTIPLE_TABLES
- wg_quick_optional_config_nob NETFILTER_XT_MARK
- wg_quick_optional_config_nob NETFILTER_XT_CONNMARK
- wg_quick_optional_config_nob IP6_NF_RAW
- wg_quick_optional_config_nob IP_NF_RAW
- fi
-
- linux-mod_pkg_setup
- kernel_is -lt 3 10 0 && die "This version of ${PN} requires Linux >= 3.10"
- fi
-}
-
-src_compile() {
- BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
- use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
- use module && linux-mod_src_compile
-}
-
-src_install() {
- use module && linux-mod_src_install
- use module-src && emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src dkms-install
-}
-
-pkg_postinst() {
- if use module-src && ! use module; then
- einfo
- einfo "You have enabled the module-src USE flag without the module USE"
- einfo "flag. This means that sources are installed to"
- einfo "${ROOT}usr/src/wireguard instead of having the"
- einfo "kernel module compiled. You will need to compile the module"
- einfo "yourself. Most likely, you don't want this USE flag, and should"
- einfo "rather use USE=module"
- einfo
- fi
- use module && linux-mod_pkg_postinst
-
- einfo
- einfo "This software is experimental and has not yet been released."
- einfo "As such, it may contain significant issues. Please do not file"
- einfo "bug reports with Gentoo, but rather direct them upstream to:"
- einfo
- einfo " team@wireguard.com security@wireguard.com"
- einfo
-
- if use tools; then
- einfo
- einfo "After installing WireGuard, if you'd like to try sending some packets through"
- einfo "WireGuard, you may use, for testing purposes only, the insecure client.sh"
- einfo "test example script:"
- einfo
- einfo " \$ bzcat ${ROOT}usr/share/doc/${PF}/examples/ncat-client-server/client.sh.bz2 | sudo bash -"
- einfo
- einfo "This will automatically setup interface wg0, through a very insecure transport"
- einfo "that is only suitable for demonstration purposes. You can then try loading the"
- einfo "hidden website or sending pings:"
- einfo
- einfo " \$ chromium http://192.168.4.1"
- einfo " \$ ping 192.168.4.1"
- einfo
- einfo "If you'd like to redirect your internet traffic, you can run it with the"
- einfo "\"default-route\" argument. You may not use this server for any abusive or illegal"
- einfo "purposes. It is for quick testing only."
- einfo
- einfo "More info on getting started can be found at: https://www.wireguard.com/quickstart/"
- einfo
- fi
- if use module; then
- local old new
- if [[ $(uname -r) != "${KV_FULL}" ]]; then
- ewarn
- ewarn "You have just built WireGuard for kernel ${KV_FULL}, yet the currently running"
- ewarn "kernel is $(uname -r). If you intend to use this WireGuard module on the currently"
- ewarn "running machine, you will first need to reboot it into the kernel ${KV_FULL}, for"
- ewarn "which this module was built."
- ewarn
- elif [[ -f /sys/module/wireguard/version ]] && \
- old="$(< /sys/module/wireguard/version)" && \
- new="$(modinfo -F version "${ROOT}/lib/modules/${KV_FULL}/net/wireguard.ko" 2>/dev/null)" && \
- [[ $old != "$new" ]]; then
- ewarn
- ewarn "You appear to have just upgraded WireGuard from version v$old to v$new."
- ewarn "However, the old version is still running on your system. In order to use the"
- ewarn "new version, you will need to remove the old module and load the new one. As"
- ewarn "root, you can accomplish this with the following commands:"
- ewarn
- ewarn " # rmmod wireguard"
- ewarn " # modprobe wireguard"
- ewarn
- ewarn "Do note that doing this will remove current WireGuard interfaces, so you may want"
- ewarn "to gracefully remove them yourself prior."
- ewarn
- fi
- fi
-}