summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYifeng Li <tomli@tomli.me>2017-05-15 09:53:33 +0800
committerPatrice Clement <monsieurp@gentoo.org>2017-05-23 16:28:22 +0200
commit1b459774031bee83e9f607f3cfffc0feba319907 (patch)
tree3eb5e0e56373fd7759ada3e94b3080395eba29dc /net-vpn
parentnet-vpn/i2p: bump to 0.9.30. (diff)
downloadgentoo-1b459774031bee83e9f607f3cfffc0feba319907.tar.gz
gentoo-1b459774031bee83e9f607f3cfffc0feba319907.tar.bz2
gentoo-1b459774031bee83e9f607f3cfffc0feba319907.zip
net-vpn/i2p: remove ecdsa flag in 0.9.30, since DSA is being replaced.
Signed-off-by: Yifeng Li <tomli@tomli.me> Closes: https://github.com/gentoo/gentoo/pull/4571
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/i2p/i2p-0.9.30.ebuild32
1 files changed, 9 insertions, 23 deletions
diff --git a/net-vpn/i2p/i2p-0.9.30.ebuild b/net-vpn/i2p/i2p-0.9.30.ebuild
index 7b4348c6cc4..c475d04fc0a 100644
--- a/net-vpn/i2p/i2p-0.9.30.ebuild
+++ b/net-vpn/i2p/i2p-0.9.30.ebuild
@@ -14,7 +14,7 @@ SLOT="0"
# Until the deps reach other arches
KEYWORDS="~amd64 ~x86"
-IUSE="+ecdsa nls"
+IUSE="nls"
# dev-java/ant-core is automatically added due to java-ant-2.eclass
CP_DEPEND="dev-java/bcprov:1.50
@@ -31,17 +31,14 @@ DEPEND="${CP_DEPEND}
>=virtual/jdk-1.7"
RDEPEND="${CP_DEPEND}
- ecdsa? (
- || (
- dev-java/icedtea:7[-sunec]
- dev-java/icedtea:8[-sunec]
- dev-java/icedtea-bin:7
- dev-java/icedtea-bin:8
- dev-java/oracle-jre-bin
- dev-java/oracle-jdk-bin
- )
- )
- !ecdsa? ( >=virtual/jre-1.7 )"
+ || (
+ dev-java/icedtea:7[-sunec]
+ dev-java/icedtea:8[-sunec]
+ dev-java/icedtea-bin:7
+ dev-java/icedtea-bin:8
+ dev-java/oracle-jre-bin
+ dev-java/oracle-jdk-bin
+ )"
EANT_BUILD_TARGET="pkg"
JAVA_ANT_ENCODING="UTF-8"
@@ -141,17 +138,6 @@ pkg_postinst() {
elog 'I2P can be configured through the web interface at http://localhost:7657/console'
elog
- if use !ecdsa
- then
- ewarn 'DSA keys are being retired since 0.9.30. You should have the ecdsa USE to ensure'
- ewarn 'the flawless operation of your i2p.'
- ewarn
- ewarn "This is purely a run-time issue. You're free to build i2p with any JDK, as long as"
- ewarn 'the JVM you run it with is one of the above listed and from the same or a newer generation'
- ewarn 'as the one you built with.'
- ewarn
- fi
-
ewarn "The router will migrate the jetty.xml for each Jetty website to the new Jetty 9 setup during startup."
ewarn "This should work for recent, unmodified configurations but may not work for modified or"
ewarn "very old setups. Verify that your Jetty website works after upgrading, and contact i2p"