summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-02-17 22:47:42 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-02-17 22:48:04 -0500
commit0bcac3f6f8afbc59b6e1d5866785bbf046257023 (patch)
treeb9af58b35a4e5875feec6bfcf404e9b4ec587200 /net-wireless/gnuradio/gnuradio-3.6.5.1-r2.ebuild
parentnet-wireless/gnuradio: add support for wx:3.0 (diff)
downloadgentoo-0bcac3f6f8afbc59b6e1d5866785bbf046257023.tar.gz
gentoo-0bcac3f6f8afbc59b6e1d5866785bbf046257023.tar.bz2
gentoo-0bcac3f6f8afbc59b6e1d5866785bbf046257023.zip
net-wireless/gnuradio: lots of work
drop old ebuilds drop wxwidgets support from 3.6 slot update to eapi 6 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-wireless/gnuradio/gnuradio-3.6.5.1-r2.ebuild')
-rw-r--r--net-wireless/gnuradio/gnuradio-3.6.5.1-r2.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/net-wireless/gnuradio/gnuradio-3.6.5.1-r2.ebuild b/net-wireless/gnuradio/gnuradio-3.6.5.1-r2.ebuild
index eeb3a09cc03..43d13099383 100644
--- a/net-wireless/gnuradio/gnuradio-3.6.5.1-r2.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.6.5.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,7 +20,7 @@ else
KEYWORDS="~amd64 ~arm ~x86"
fi
-IUSE="alsa +analog +digital doc examples fcd +filter grc jack oss pager performance-counters portaudio qt4 sdl uhd +utils wavelet wxwidgets"
+IUSE="alsa +analog +digital doc examples fcd +filter grc jack oss pager performance-counters portaudio qt4 sdl uhd +utils wavelet"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
analog? ( filter )
@@ -29,8 +29,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
qt4? ( filter )
uhd? ( filter analog )
fcd? ( || ( alsa oss ) )
- wavelet? ( analog )
- wxwidgets? ( filter analog )"
+ wavelet? ( analog )"
# bug #348206
# comedi? ( >=sci-electronics/comedilib-0.7 )
@@ -66,10 +65,6 @@ RDEPEND="${PYTHON_DEPS}
wavelet? (
sci-libs/gsl
)
- wxwidgets? (
- dev-python/wxpython:2.8[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
"
DEPEND="${RDEPEND}
dev-lang/swig
@@ -113,9 +108,9 @@ src_configure() {
$(cmake-utils_use_enable uhd GR_UHD) \
$(cmake-utils_use_enable utils GR_UTILS) \
$(cmake-utils_use_enable wavelet GR_WAVELET) \
- $(cmake-utils_use_enable wxwidgets GR_WXGUI) \
$(cmake-utils_use_enable qt4 GR_QTGUI) \
$(cmake-utils_use_enable sdl GR_VIDEO_SDL) \
+ -DENABLE_GR_WXGUI=OFF \
-DENABLE_GR_CORE=ON \
-DSYSCONFDIR="${EPREFIX}"/etc \
-DPYTHON_EXECUTABLE="${PYTHON}"