summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-11-05 20:56:29 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-11-05 20:56:42 -0500
commitbf067039d6f74e08f8d627391d2daa0823b01277 (patch)
treef212791a8d7a82865fa6fc1902e28239edc9b4db /net-wireless
parentdev-python/blurb: New package (diff)
downloadgentoo-bf067039d6f74e08f8d627391d2daa0823b01277.tar.gz
gentoo-bf067039d6f74e08f8d627391d2daa0823b01277.tar.bz2
gentoo-bf067039d6f74e08f8d627391d2daa0823b01277.zip
net-wireless/kismet: live ebuild update
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/kismet/files/fix-setuptools2.patch65
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild4
2 files changed, 67 insertions, 2 deletions
diff --git a/net-wireless/kismet/files/fix-setuptools2.patch b/net-wireless/kismet/files/fix-setuptools2.patch
new file mode 100644
index 000000000000..2f72b258af99
--- /dev/null
+++ b/net-wireless/kismet/files/fix-setuptools2.patch
@@ -0,0 +1,65 @@
+diff --git a/capture_freaklabs_zigbee/Makefile.in b/capture_freaklabs_zigbee/Makefile.in
+index 97fb50b7..492f6a90 100644
+--- a/capture_freaklabs_zigbee/Makefile.in
++++ b/capture_freaklabs_zigbee/Makefile.in
+@@ -6,7 +6,7 @@ all:
+ $(PYTHON3) ./setup.py build
+
+ install:
+- $(PYTHON3) ./setup.py install
++ $(PYTHON3) ./setup.py install --root=$(DESTDIR)
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+
+ clean:
+diff --git a/capture_sdr_rtl433/Makefile.in b/capture_sdr_rtl433/Makefile.in
+index 2e82ac5f..fa4314b2 100644
+--- a/capture_sdr_rtl433/Makefile.in
++++ b/capture_sdr_rtl433/Makefile.in
+@@ -7,7 +7,7 @@ all:
+ $(PYTHON3) ./setup.py build
+
+ install:
+- $(PYTHON3) ./setup.py install
++ $(PYTHON3) ./setup.py install --root=$(DESTDIR)
+ # These are now part of the setup.py install
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MQTTMONITOR_BIN) $(BIN)/$(MQTTMONITOR_BIN)
+diff --git a/python_modules/KismetExternal/Makefile b/python_modules/KismetExternal/Makefile
+index 4dc83d11..4bf912b3 100644
+--- a/python_modules/KismetExternal/Makefile
++++ b/python_modules/KismetExternal/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON3) ./setup.py build
+
+ install:
+- $(PYTHON3) ./setup.py install
++ $(PYTHON3) ./setup.py install --root=$(DESTDIR)
+
+ protobuf:
+ $(PROTOCBIN) -I ../../protobuf_definitions --python_out=./KismetExternal ../../protobuf_definitions/*.proto
+diff --git a/python_modules/KismetLog/Makefile b/python_modules/KismetLog/Makefile
+index 910ca9d9..cafd3902 100644
+--- a/python_modules/KismetLog/Makefile
++++ b/python_modules/KismetLog/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON3) ./setup.py build
+
+ install:
+- $(PYTHON3) ./setup.py install
++ $(PYTHON3) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON3) ./setup.py clean
+diff --git a/python_modules/KismetRest/Makefile b/python_modules/KismetRest/Makefile
+index 910ca9d9..cafd3902 100644
+--- a/python_modules/KismetRest/Makefile
++++ b/python_modules/KismetRest/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON3) ./setup.py build
+
+ install:
+- $(PYTHON3) ./setup.py install
++ $(PYTHON3) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON3) ./setup.py clean
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 1964da67d1e6..4ef4ac444ddd 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_6 )
inherit autotools eutils multilib user python-single-r1
@@ -66,7 +66,7 @@ src_prepare() {
sed -i -e 's| -s||g' \
-e 's|@mangrp@|root|g' Makefile.in
- epatch "${FILESDIR}"/fix-setuptools.patch
+ epatch "${FILESDIR}"/fix-setuptools2.patch
eapply_user
if [[ ${PV} == "9999" ]] ; then