summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:38:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:38:57 +0200
commit5479e798a6969fee1f224bd63a96b65c1e5657f0 (patch)
tree2ba5c8f908efc1842674a3675c2fb33ae39ec137 /ros-meta
parentros-meta/rqt_robot_plugins: Initial import. Ebuild by me. (diff)
downloadgentoo-5479e798a6969fee1f224bd63a96b65c1e5657f0.tar.gz
gentoo-5479e798a6969fee1f224bd63a96b65c1e5657f0.tar.bz2
gentoo-5479e798a6969fee1f224bd63a96b65c1e5657f0.zip
ros-meta/viz: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta')
-rw-r--r--ros-meta/viz/Manifest1
-rw-r--r--ros-meta/viz/metadata.xml5
-rw-r--r--ros-meta/viz/viz-1.2.0.ebuild24
-rw-r--r--ros-meta/viz/viz-9999.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/ros-meta/viz/Manifest b/ros-meta/viz/Manifest
new file mode 100644
index 000000000000..7ebda7a747f6
--- /dev/null
+++ b/ros-meta/viz/Manifest
@@ -0,0 +1 @@
+DIST metapackages-1.2.0.tar.gz 1803 SHA256 02360aefee1a3ec8506cb475be00a053827d422fed26d123764b4d6b18b0a5c5 SHA512 a004a1323c93e191b98a4fe665409fb57396fb06c19e9205817f2467e171bfba10a86713978e13739632e04f148b476e582c6f1fd3c859b4936980923f204e80 WHIRLPOOL 1bb4a73678613dd6fe6b0d1225b3fd967fbb476e5736949846f3297febf727f41c9d3e71565b13dcc90d36d57a6cf012a3cdad509ed4364bb87de7e372c69a79
diff --git a/ros-meta/viz/metadata.xml b/ros-meta/viz/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/ros-meta/viz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/viz/viz-1.2.0.ebuild b/ros-meta/viz/viz-1.2.0.ebuild
new file mode 100644
index 000000000000..86debcf21210
--- /dev/null
+++ b/ros-meta/viz/viz-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for ROS visualization packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/ros_base
+ ros-meta/rqt_common_plugins
+ ros-meta/rqt_robot_plugins
+ dev-ros/rviz
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/viz/viz-9999.ebuild b/ros-meta/viz/viz-9999.ebuild
new file mode 100644
index 000000000000..86debcf21210
--- /dev/null
+++ b/ros-meta/viz/viz-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for ROS visualization packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/ros_base
+ ros-meta/rqt_common_plugins
+ ros-meta/rqt_robot_plugins
+ dev-ros/rviz
+"
+DEPEND="${RDEPEND}"