summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 13:13:29 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 13:13:29 +0100
commit8504665f049c6622589119393d216db2a55e150c (patch)
treebc722c43d3073132aedd50656509c52c158c1961 /ros-meta
parentros-meta/hector_slam: Bump to 0.4.0. (diff)
downloadgentoo-8504665f049c6622589119393d216db2a55e150c.tar.gz
gentoo-8504665f049c6622589119393d216db2a55e150c.tar.bz2
gentoo-8504665f049c6622589119393d216db2a55e150c.zip
ros-meta/ament_cmake: specify transitive deps for usedeps
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'ros-meta')
-rw-r--r--ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild4
-rw-r--r--ros-meta/ament_cmake/ament_cmake-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild b/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
index 9424ebe9198..916839c82df 100644
--- a/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
+++ b/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
@@ -44,7 +44,11 @@ DEPEND="
dev-ros/ament_cmake_test[${PYTHON_USEDEP}]
dev-ros/ament_cmake_version[${PYTHON_USEDEP}]
${PYTHON_DEPS}
+
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
"
+# Last batch of deps above are transitive (from ament_cmake_core) but we need this to propagate proper deps
RDEPEND="${DEPEND}"
BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/ros-meta/ament_cmake/ament_cmake-9999.ebuild b/ros-meta/ament_cmake/ament_cmake-9999.ebuild
index 9424ebe9198..916839c82df 100644
--- a/ros-meta/ament_cmake/ament_cmake-9999.ebuild
+++ b/ros-meta/ament_cmake/ament_cmake-9999.ebuild
@@ -44,7 +44,11 @@ DEPEND="
dev-ros/ament_cmake_test[${PYTHON_USEDEP}]
dev-ros/ament_cmake_version[${PYTHON_USEDEP}]
${PYTHON_DEPS}
+
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
"
+# Last batch of deps above are transitive (from ament_cmake_core) but we need this to propagate proper deps
RDEPEND="${DEPEND}"
BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"