summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-19 12:54:21 +0000
committerSam James <sam@gentoo.org>2021-02-19 12:54:21 +0000
commit8b38bdb3a81216a364682bbba9a002dd205e9cba (patch)
tree19fb04c5fed2c21f212fe30f5c39172bf38acc6e /sci-astronomy
parentmedia-libs/libilbc: restore patch (diff)
downloadgentoo-8b38bdb3a81216a364682bbba9a002dd205e9cba.tar.gz
gentoo-8b38bdb3a81216a364682bbba9a002dd205e9cba.tar.bz2
gentoo-8b38bdb3a81216a364682bbba9a002dd205e9cba.zip
sci-astronomy/wcslib: workaround gcc 10 (fortran) failure
Closes: https://bugs.gentoo.org/764548 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/wcslib-7.3.1.ebuild7
-rw-r--r--sci-astronomy/wcslib/wcslib-7.3.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/sci-astronomy/wcslib/wcslib-7.3.1.ebuild b/sci-astronomy/wcslib/wcslib-7.3.1.ebuild
index a7feb7d418e8..c6f97ef59730 100644
--- a/sci-astronomy/wcslib/wcslib-7.3.1.ebuild
+++ b/sci-astronomy/wcslib/wcslib-7.3.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2
+inherit fortran-2 flag-o-matic
DESCRIPTION="Astronomical World Coordinate System transformations library"
HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
@@ -24,12 +24,17 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
+ # GCC 10 workaround
+ # bug #764548
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
local myconf=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--htmldir="${EPREFIX}"/usr/share/doc/${PF}
$(use_enable fortran)
$(use_enable tools utils)
)
+
# hacks because cfitsio and pgplot directories are hard-coded
if use fits; then
myconf+=(
diff --git a/sci-astronomy/wcslib/wcslib-7.3.ebuild b/sci-astronomy/wcslib/wcslib-7.3.ebuild
index 9333d9e13c38..a01c6a87494c 100644
--- a/sci-astronomy/wcslib/wcslib-7.3.ebuild
+++ b/sci-astronomy/wcslib/wcslib-7.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2
+inherit fortran-2 flag-o-matic
DESCRIPTION="Astronomical World Coordinate System transformations library"
HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
@@ -24,12 +24,17 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
+ # GCC 10 workaround
+ # bug #764548
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
local myconf=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--htmldir="${EPREFIX}"/usr/share/doc/${PF}
$(use_enable fortran)
$(use_enable tools utils)
)
+
# hacks because cfitsio and pgplot directories are hard-coded
if use fits; then
myconf+=(