summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-16 13:32:54 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-16 14:16:45 +0100
commitacd76729254ed012b6898eb33fcc59ab8c2076e4 (patch)
tree60057fa3db0a39a972284f8ab622544d5fecf0a7 /sci-biology/STAR/STAR-2.5.3a.ebuild
parentsci-biology/HTSeq: Initial addition (diff)
downloadgentoo-acd76729254ed012b6898eb33fcc59ab8c2076e4.tar.gz
gentoo-acd76729254ed012b6898eb33fcc59ab8c2076e4.tar.bz2
gentoo-acd76729254ed012b6898eb33fcc59ab8c2076e4.zip
sci-biology/STAR: Initial addition
Closes: https://github.com/gentoo/sci/pull/814 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'sci-biology/STAR/STAR-2.5.3a.ebuild')
-rw-r--r--sci-biology/STAR/STAR-2.5.3a.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/STAR/STAR-2.5.3a.ebuild b/sci-biology/STAR/STAR-2.5.3a.ebuild
new file mode 100644
index 000000000000..73743cbb4e59
--- /dev/null
+++ b/sci-biology/STAR/STAR-2.5.3a.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="STAR aligner: align RNA-seq reads to reference genome uncompressed suffix arrays"
+HOMEPAGE="https://github.com/alexdobin/STAR"
+SRC_URI="https://github.com/alexdobin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="sci-libs/htslib:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.5.3a-fix-build-system.patch )
+DOCS=( README.md CHANGES.md RELEASEnotes.md doc/STARmanual.pdf )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_configure() {
+ tc-export CC CXX PKG_CONFIG
+}
+
+src_compile() {
+ emake -C source STAR
+}
+
+src_install() {
+ dobin source/STAR
+ einstalldocs
+}