summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-07 21:56:44 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-07 21:56:44 +0200
commitac9f7506edd581e5f00442c1137775908b1ada93 (patch)
tree7d027b499031b7e4ba2a87c6d5ef4b625c7374d7 /sci-biology/biosql/biosql-1.0.1-r2.ebuild
parentsci-biology/biogrep: update EAPI 6 -> 8 (diff)
downloadgentoo-ac9f7506edd581e5f00442c1137775908b1ada93.tar.gz
gentoo-ac9f7506edd581e5f00442c1137775908b1ada93.tar.bz2
gentoo-ac9f7506edd581e5f00442c1137775908b1ada93.zip
sci-biology/biosql: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/biosql/biosql-1.0.1-r2.ebuild')
-rw-r--r--sci-biology/biosql/biosql-1.0.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/biosql/biosql-1.0.1-r2.ebuild b/sci-biology/biosql/biosql-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..c32ff970f9af
--- /dev/null
+++ b/sci-biology/biosql/biosql-1.0.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A generic bioinformatics relational database model"
+HOMEPAGE="http://www.biosql.org/"
+SRC_URI="http://biosql.org/DIST/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="mysql postgres"
+
+# WARNING: bioperl-db is claimed to be incompatible with >=postgresql-8.3 (see INSTALL)
+
+DEPEND="
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl"
+
+src_install() {
+ insinto /usr/share/biosql
+ doins -r sql scripts/.
+
+ dodoc Changes README Release.txt doc/*.pdf
+
+ docinto biopython
+ dodoc doc/{README,schema-overview.txt,biopython/{cor6_6.gb,*.pdf}}
+ docompress -x /usr/share/doc/${PF}/biopython
+
+ docinto html
+ dodoc doc/{biopython/,}*.htm*
+}
+
+pkg_postinst() {
+ elog
+ elog "Please read the BioSQL schema installation instructions in"
+ elog "${EROOT}/usr/share/doc/${PF} to begin using the schema."
+ elog
+}