summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2018-09-14 12:01:06 -0400
committerIan Stakenvicius <axs@gentoo.org>2018-09-14 12:02:20 -0400
commit713a32f1da038d5f33ea20728a32b22874b223aa (patch)
tree852d5719da4cc0c1cff686b35fb2b5aa624b3c6b /sci-biology/foldingathome
parentx11-wm/xpra: Fix deps for x264 x265 encoders (diff)
downloadgentoo-713a32f1da038d5f33ea20728a32b22874b223aa.tar.gz
gentoo-713a32f1da038d5f33ea20728a32b22874b223aa.tar.bz2
gentoo-713a32f1da038d5f33ea20728a32b22874b223aa.zip
sci-biology/foldingathome: bump to 7.5.1
Upstream has dropped support for 32bit Closes: https://bugs.gentoo.org/666208 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-biology/foldingathome')
-rw-r--r--sci-biology/foldingathome/Manifest3
-rw-r--r--sci-biology/foldingathome/foldingathome-7.5.1.ebuild (renamed from sci-biology/foldingathome/foldingathome-7.4.4-r3.ebuild)30
2 files changed, 18 insertions, 15 deletions
diff --git a/sci-biology/foldingathome/Manifest b/sci-biology/foldingathome/Manifest
index 4c422074476a..e611180008f8 100644
--- a/sci-biology/foldingathome/Manifest
+++ b/sci-biology/foldingathome/Manifest
@@ -1,2 +1 @@
-DIST fahclient_7.4.4-32bit-release.tar.bz2 4313096 BLAKE2B bb0c0e2d2cb577e0e3e668aeb3521e900a1947dc42fd18e2976216de113e725c3c68872b1c43666a81acfbb2a447d9facf774d7011c451779ee1fb310caff91f SHA512 6a660b99c97c83518863ef671ae760b15e3ca33cacfde6485c11b29e98fab15a9d27833ba307c95b39e6ffb7f271cd0c7a47060ec5b8614961e9a5ee46494b3f
-DIST fahclient_7.4.4-64bit-release.tar.bz2 4451080 BLAKE2B a22b65d0415a291a53d222fbc98f62c93490b08530f1c091b6cf9fb8e1abe4b7a5649c4c008f00a9a75ab4d2066fe5ed1fcb70ef08430842a9643a958a90a1a4 SHA512 40fc93c4ec682342040a4c7a9fd92dc9d1727ef60af6d3fa3191575719c7e595868f289727561f6902f8374061f7b51dfcf565ac047706336ef4ae9a589ff9a8
+DIST fahclient_7.5.1-64bit-release.tar.bz2 3438239 BLAKE2B 69fb60cdd5356fe4f5ad1f106b67d078baf0394c5d3c474dff2f1ac840bcb31bfd9ca9a9c6112b9ee9497dcdc223732627a21c50b455e46c096a52587d5d229b SHA512 5f6f2f882d57fe53ad0a55b48f09fc3803af6aebbbf0e92be39477d4c4da92237d6edabec61dd8183678bdcfe3923ff9b0938647a77edc2c69ce8958defcfdf1
diff --git a/sci-biology/foldingathome/foldingathome-7.4.4-r3.ebuild b/sci-biology/foldingathome/foldingathome-7.5.1.ebuild
index 5df01b800ba7..f842c8814c78 100644
--- a/sci-biology/foldingathome/foldingathome-7.4.4-r3.ebuild
+++ b/sci-biology/foldingathome/foldingathome-7.5.1.ebuild
@@ -5,29 +5,26 @@ EAPI=6
inherit versionator user systemd
-MY_BASEURI="https://fah.stanford.edu/file-releases/public/release/fahclient"
-MY_64B_URI="${MY_BASEURI}/centos-5.3-64bit/v$(get_version_component_range 1-2)/fahclient_${PV}-64bit-release.tar.bz2"
-MY_32B_URI="${MY_BASEURI}/centos-5.5-32bit/v$(get_version_component_range 1-2)/fahclient_${PV}-32bit-release.tar.bz2"
-
DESCRIPTION="Folding@Home is a distributed computing project for protein folding"
-HOMEPAGE="http://folding.stanford.edu/FAQ-SMP.html"
-SRC_URI="x86? ( ${MY_32B_URI} )
- amd64? ( ${MY_64B_URI} )"
+HOMEPAGE="https://foldingathome.org/"
+SRC_URI="https://download.foldingathome.org/releases/public/release/fahclient/centos-6.7-64bit/v$(get_version_component_range 1-2)/fahclient_${PV}-64bit-release.tar.bz2"
RESTRICT="mirror bindist strip"
LICENSE="FAH-EULA-2014 FAH-special-permission"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
IUSE=""
# Expressly listing all deps, as this is a binpkg and it is doubtful whether
# i.e. uclibc or clang can provide what is necessary at runtime
+DEPEND="dev-util/patchelf"
RDEPEND="app-arch/bzip2
+ =dev-libs/openssl-1.0*:*
sys-devel/gcc
sys-libs/glibc
sys-libs/zlib"
-S="${WORKDIR}"
+S="${WORKDIR}/fahclient_${PV}-64bit-release"
QA_PREBUILT="opt/foldingathome/*"
@@ -47,10 +44,17 @@ pkg_setup() {
}
src_install() {
- local myS="fahclient_${PV}-64bit-release"
- use x86 && myS="${myS//64bit/32bit}"
+ patchelf --set-rpath "${EPREFIX}/opt/foldingathome" FAHClient || die
+ patchelf --set-rpath "${EPREFIX}/opt/foldingathome" FAHCoreWrapper || die
+
+ dosym "../../usr/$(get_libdir)/libssl.so.1.0.0" /opt/foldingathome/libssl.so.10
+ dosym "../../usr/$(get_libdir)/libcrypto.so.1.0.0" /opt/foldingathome/libcrypto.so.10
+
exeinto /opt/foldingathome
- doexe "${myS}"/{FAHClient,FAHCoreWrapper}
+ doexe {FAHClient,FAHCoreWrapper}
+
+ insinto /opt/foldingathome
+ doins sample-config.xml
newconfd "${FILESDIR}"/7.3/folding-conf.d foldingathome
cat <<EOF >"${T}"/fah-init
@@ -70,7 +74,7 @@ EOF
cat <<EOF >"${T}"/fah-init.service
[Unit]
Description=Folding@Home V7 Client
-Documentation=https://folding.stanford.edu/home/the-software/
+Documentation=https://foldingathome.org
[Service]
Type=simple