summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/muscle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/muscle')
-rw-r--r--sci-biology/muscle/Manifest1
-rw-r--r--sci-biology/muscle/files/3.7-bufferoverflow.patch26
-rw-r--r--sci-biology/muscle/files/3.8.31-make.patch26
-rw-r--r--sci-biology/muscle/metadata.xml5
-rw-r--r--sci-biology/muscle/muscle-3.8.31.ebuild33
5 files changed, 91 insertions, 0 deletions
diff --git a/sci-biology/muscle/Manifest b/sci-biology/muscle/Manifest
new file mode 100644
index 000000000000..2dbd476bb5b4
--- /dev/null
+++ b/sci-biology/muscle/Manifest
@@ -0,0 +1 @@
+DIST muscle3.8.31_src.tar.gz 515267 SHA256 43c5966a82133bd7da5921e8142f2f592c2b5f53d802f0527a2801783af809ad SHA512 2baf2aae354ae1e3f529e627be2ace86e89dd15567e1f642a625b63f08ebe3d4bd7315080c7d786d95e3eda8703545ec74af9fe83ad1523d55d00137fb7274ce WHIRLPOOL daea88aaeaaacf5a2da68484010091ae46c69713659f92f45e5e2096af9e7d8c645d14e5b6c4c8e73e4df35a086dee823fcab6d442cd3881b773fb0113ce897d
diff --git a/sci-biology/muscle/files/3.7-bufferoverflow.patch b/sci-biology/muscle/files/3.7-bufferoverflow.patch
new file mode 100644
index 000000000000..670ad64959cb
--- /dev/null
+++ b/sci-biology/muscle/files/3.7-bufferoverflow.patch
@@ -0,0 +1,26 @@
+diff --git a/globalslinux.cpp b/globalslinux.cpp
+index 63baaa1..b1cfcb0 100644
+--- a/globalslinux.cpp
++++ b/globalslinux.cpp
+@@ -156,7 +156,7 @@ double GetRAMSizeMB()
+ }
+ return DEFAULT_RAM;
+ }
+- int Bytes = atoi(pMem+9)*1000;
++ long Bytes = atol(pMem+9)*1000;
+ return ((double) Bytes)/1e6;
+ }
+
+diff --git a/progress.cpp b/progress.cpp
+index a0e91bb..f9b093e 100644
+--- a/progress.cpp
++++ b/progress.cpp
+@@ -41,7 +41,7 @@ const char *MemToStr(double MB)
+ if (MB < 0)
+ return "";
+
+- static char Str[9];
++ static char Str[16];
+ static double MaxMB = 0;
+ static double RAMMB = 0;
+
diff --git a/sci-biology/muscle/files/3.8.31-make.patch b/sci-biology/muscle/files/3.8.31-make.patch
new file mode 100644
index 000000000000..7c0e7308df54
--- /dev/null
+++ b/sci-biology/muscle/files/3.8.31-make.patch
@@ -0,0 +1,26 @@
+diff --git a/src/mk b/src/mk
+index 475d25a..d4b7e83 100755
+--- a/src/mk
++++ b/src/mk
+@@ -5,17 +5,14 @@ ObjNames='aligngivenpath.o aligngivenpathsw.o aligntwomsas.o aligntwoprofs.o aln
+ rm -f *.o muscle.make.stdout.txt muscle.make.stderr.txt
+ for CPPName in $CPPNames
+ do
+- echo $CPPName >> /dev/tty
+- g++ $ENV_GCC_OPTS -c -O3 -msse2 -mfpmath=sse -D_FILE_OFFSET_BITS=64 -DNDEBUG=1 $CPPName.cpp -o $CPPName.o >> muscle.make.stdout.txt 2>> muscle.make.stderr.txt
++ echo "${CXX} ${CXXFLAGS} -c -D_FILE_OFFSET_BITS=64 -DNDEBUG=1 $CPPName.cpp -o $CPPName.o"
++ ${CXX} ${CXXFLAGS} -c -D_FILE_OFFSET_BITS=64 -DNDEBUG=1 $CPPName.cpp -o $CPPName.o
+ done
+
+ LINK_OPTS=
+ if [ `uname -s` == Linux ] ; then
+ LINK_OPTS=-static
+ fi
+-g++ $LINK_OPTS $ENV_LINK_OPTS -g -o muscle $ObjNames >> muscle.make.stdout.txt 2>> muscle.make.stderr.txt
+-tail muscle.make.stderr.txt
+
+-strip muscle
+-ls -lh muscle
+-sum muscle
++echo "${CXX} ${LDFLAGS} -o muscle $ObjNames"
++${CXX} ${LDFLAGS} -o muscle $ObjNames
diff --git a/sci-biology/muscle/metadata.xml b/sci-biology/muscle/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/muscle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/muscle/muscle-3.8.31.ebuild b/sci-biology/muscle/muscle-3.8.31.ebuild
new file mode 100644
index 000000000000..555419da883f
--- /dev/null
+++ b/sci-biology/muscle/muscle-3.8.31.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}${PV}_src"
+
+DESCRIPTION="Multiple sequence comparison by log-expectation"
+HOMEPAGE="http://www.drive5.com/muscle/"
+SRC_URI="http://www.drive5.com/muscle/downloads${PV}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="!sci-libs/libmuscle"
+DEPEND=""
+
+S="${WORKDIR}"/${PN}${PV}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-make.patch
+ tc-export CXX
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc *.txt
+}