summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-07 15:13:13 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-07 15:13:13 +0200
commit1f20252245bf55c15c8664783024d06c1eaf6c6a (patch)
tree04520e4f0155100daac39fefc42410b1faadd15d /sci-biology
parentsys-devel/gcc: drop 6.5.0-r4, 7.5.0-r2 (diff)
downloadgentoo-1f20252245bf55c15c8664783024d06c1eaf6c6a.tar.gz
gentoo-1f20252245bf55c15c8664783024d06c1eaf6c6a.tar.bz2
gentoo-1f20252245bf55c15c8664783024d06c1eaf6c6a.zip
sci-biology/STAR: fix GCC 12 build
Closes: https://bugs.gentoo.org/840586 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/STAR/STAR-2.7.10a.ebuild5
-rw-r--r--sci-biology/STAR/files/STAR-2.7.10a-missing-include.patch22
2 files changed, 26 insertions, 1 deletions
diff --git a/sci-biology/STAR/STAR-2.7.10a.ebuild b/sci-biology/STAR/STAR-2.7.10a.ebuild
index 7239efcfe45c..c3deb5a94b0a 100644
--- a/sci-biology/STAR/STAR-2.7.10a.ebuild
+++ b/sci-biology/STAR/STAR-2.7.10a.ebuild
@@ -17,7 +17,10 @@ RDEPEND="sci-libs/htslib:="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${PN}-2.7.10a-fix-build-system.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.10a-fix-build-system.patch
+ "${FILESDIR}"/${PN}-2.7.10a-missing-include.patch
+)
DOCS=( README.md CHANGES.md RELEASEnotes.md doc/STARmanual.pdf )
pkg_pretend() {
diff --git a/sci-biology/STAR/files/STAR-2.7.10a-missing-include.patch b/sci-biology/STAR/files/STAR-2.7.10a-missing-include.patch
new file mode 100644
index 000000000000..c056a8aad887
--- /dev/null
+++ b/sci-biology/STAR/files/STAR-2.7.10a-missing-include.patch
@@ -0,0 +1,22 @@
+From f5ad94329db4fd81fc6ae30684c298772002e30b Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Sat, 7 May 2022 15:06:11 +0200
+Subject: [PATCH] Add missing `#include <array>` (GCC 12)
+
+Bug: https://bugs.gentoo.org/840586
+---
+ source/SoloCommon.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/source/SoloCommon.h b/source/SoloCommon.h
+index 2a1d5fcf..5adc5040 100644
+--- a/source/SoloCommon.h
++++ b/source/SoloCommon.h
+@@ -1,6 +1,7 @@
+ #ifndef H_SoloCommon
+ #define H_SoloCommon
+
++#include <array>
+ #include <unordered_map>
+
+ typedef struct{