summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-10-19 20:11:00 +0300
committerSergey Popov <pinkbyte@gentoo.org>2015-10-19 20:11:21 +0300
commitc337e46391e9fbbc1e639f860cd7b3eb72bdb536 (patch)
treee7937dcd6818b8ddf917e63e96c211089de37e69 /sci-biology
parentdev-python/coverage: Add pypy* support (diff)
downloadgentoo-c337e46391e9fbbc1e639f860cd7b3eb72bdb536.tar.gz
gentoo-c337e46391e9fbbc1e639f860cd7b3eb72bdb536.tar.bz2
gentoo-c337e46391e9fbbc1e639f860cd7b3eb72bdb536.zip
sci-biology/seqan: correct dependency on sci-biology/samtools
Seqan 1.3.1 does not compile with samtools greater than 0.1.19 Also it does not compile with GCC 4.9 or higher, so restrict this too Gentoo-Bug: 514250 Package-Manager: portage-2.2.20
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/seqan/seqan-1.3.1-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sci-biology/seqan/seqan-1.3.1-r1.ebuild b/sci-biology/seqan/seqan-1.3.1-r1.ebuild
index a74eac3ccfc..2bcb7f651f5 100644
--- a/sci-biology/seqan/seqan-1.3.1-r1.ebuild
+++ b/sci-biology/seqan/seqan-1.3.1-r1.ebuild
@@ -20,11 +20,19 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- sci-biology/samtools"
+ ~sci-biology/samtools-0.1.19"
DEPEND="${RDEPEND}"
S="${WORKDIR}"/${P}/cmake
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -gt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -gt 8 ]] ) \
+ && die "Sorry, but gcc 4.9 or higher is unsupported"
+ fi
+}
+
src_prepare() {
append-cppflags -I"${EPREFIX}/usr/include/bam"
rm -rf "${S}"/../lib/samtools || die