summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-12 13:49:31 +0000
committerSam James <sam@gentoo.org>2021-02-12 13:49:31 +0000
commit6bcb78c4c5267464584160e4a53c623e2442f66b (patch)
tree41e5c48a40bfd01b4273ce718e99589562ce1762 /sci-calculators/units
parentapp-text/djvu: Stabilize 3.5.28 amd64, #770031 (diff)
downloadgentoo-6bcb78c4c5267464584160e4a53c623e2442f66b.tar.gz
gentoo-6bcb78c4c5267464584160e4a53c623e2442f66b.tar.bz2
gentoo-6bcb78c4c5267464584160e4a53c623e2442f66b.zip
sci-calculators/units: cleanup old
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-calculators/units')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/files/units-2.20-WIN32.patch24
-rw-r--r--sci-calculators/units/units-2.20.ebuild60
3 files changed, 0 insertions, 85 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index 551e57acabc4..62a5de36de3f 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1,2 +1 @@
-DIST units-2.20.tar.gz 1309242 BLAKE2B 5321e6234cfe4514d1ebccec490e472ff64a0428bb2721f51e3ff626ddef7eec4b4e8822aa947da1f4ddca414078b617ba34308c86a71788f6d8a9ba20dd6846 SHA512 5292588fb7ea0ab12e45e5521a115a0eaba4e37378011677cbd80e6e17a6ffa5f388a57859c590b6d65460fc91a4ff33e6603e27d4909b8122d4ad3696c8600d
DIST units-2.21.tar.gz 1308533 BLAKE2B 0a02979eafa21af759128ec72b11e1f532640c9d0e88ae8f389a1beb52d5a400cbd6294042aa4c7d8786c06c8ac4106a77c302805b8c5e3bb84d4134805fd517 SHA512 34bacff606f12aa5b2e59170f6b2142277aa1121d79610a51b57f07f17ae2dbdfbbb0e60be34522f367679cc152408f77c1ebb551016224d23f81c21f4b3ba62
diff --git a/sci-calculators/units/files/units-2.20-WIN32.patch b/sci-calculators/units/files/units-2.20-WIN32.patch
deleted file mode 100644
index fbe7599831c4..000000000000
--- a/sci-calculators/units/files/units-2.20-WIN32.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/units.c
-+++ b/units.c
-@@ -4087,7 +4087,9 @@
- checkcwd (char *file)
- {
- FILE *fp;
-+#ifdef _WIN32
- char *p;
-+#endif
-
- fp = fopen(file, "r");
- if (fp){
-@@ -4630,7 +4630,10 @@
- printversion()
- {
- int exists;
-- char *unitsfile, *localemap;
-+ char *unitsfile;
-+#ifdef _WIN32
-+ char *localemap;
-+#endif
-
- if (flags.verbose == 0) {
- printf("GNU Units version %s\n", VERSION);
diff --git a/sci-calculators/units/units-2.20.ebuild b/sci-calculators/units/units-2.20.ebuild
deleted file mode 100644
index f63f622a0410..000000000000
--- a/sci-calculators/units/units-2.20.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit python-r1
-
-DESCRIPTION="Unit conversion program"
-HOMEPAGE="https://www.gnu.org/software/units/units.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="FDL-1.3 GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units-cur"
-REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- sys-libs/readline:=
- units-cur? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- )
-"
-DEPEND="
- ${RDEPEND}
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
- "${FILESDIR}"/${PN}-2.20-WIN32.patch
- "${FILESDIR}"/${PN}-2.20-readerror.patch
-)
-DOCS=(
- ChangeLog NEWS README
-)
-
-src_configure() {
- econf \
- --sharedstatedir="${EPREFIX}"/var/lib \
- ac_cv_path_PYTHON=no
-}
-
-src_compile() {
- emake ${PN}
-}
-
-src_install() {
- default
-
- if use units-cur; then
- sed \
- -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
- -e 's|^#!|&/usr/bin/python|g' \
- units_cur_inst > units_cur || die
- python_foreach_impl python_doscript units_cur
- fi
-}