summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/burrow-owl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/burrow-owl')
-rw-r--r--sci-chemistry/burrow-owl/Manifest2
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild53
-rw-r--r--sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch38
-rw-r--r--sci-chemistry/burrow-owl/files/1.4-include.patch12
-rw-r--r--sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch20
-rw-r--r--sci-chemistry/burrow-owl/metadata.xml8
6 files changed, 133 insertions, 0 deletions
diff --git a/sci-chemistry/burrow-owl/Manifest b/sci-chemistry/burrow-owl/Manifest
new file mode 100644
index 000000000000..8b584ea4ad29
--- /dev/null
+++ b/sci-chemistry/burrow-owl/Manifest
@@ -0,0 +1,2 @@
+DIST burrow-demos.tar 80896000 SHA256 f93e957889adab0521c6e3234f117cf984b7bb18ba6641a3edbdd30202db4b96 SHA512 76948846b4bff2f5c0814e41ee1745122580d6e28f8de217edbf42c4530bc64fb093dc9c96e9c0c083098755c525300b563ee1368caa12be791b2bea7015ee6b WHIRLPOOL 88ca227d8e808814187630c9568e927620a0dc4fb0eba4131ab14cae842aa778fda6294b32e8ec0e23224fca3b5a2a65609ed7f97a34691267439a557bfa0c42
+DIST burrow-owl-1.5.1.tar.gz 1408249 SHA256 76a4ab0746b1b945e0177d441f7ced8042063d4ff2c9171343ea20ddc19a9bbb SHA512 38b428c8b40cdca6caabc7ed9d247118dbf67b537afaec3af14909353d6b138fdf98a33dee6241ce5224631e16c4dbce11b9aadcfe01fecf92f1aae692ce71e1 WHIRLPOOL e165b0508b28e03a47c77ee72ea0d2347ef9088fe33df9788935e3ec0906efd511f77eebe27d74ed79a913f420cde015a39faebdc3195edc1d279ac0d607d39b
diff --git a/sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild b/sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild
new file mode 100644
index 000000000000..76018815c9cd
--- /dev/null
+++ b/sci-chemistry/burrow-owl/burrow-owl-1.5.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils virtualx
+
+DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ examples? ( mirror://sourceforge/${PN}/burrow-demos.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+
+RDEPEND="
+ dev-libs/g-wrap
+ dev-libs/glib:2
+ dev-scheme/guile[networking,regex]
+ dev-scheme/guile-cairo
+ dev-scheme/guile-gnome-platform
+ sci-libs/starparse
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/indent
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc doxygen doxygen)
+ )
+ autotools-utils_src_configure
+}
+
+src_test () {
+ cd "${AUTOTOOLS_BUILD_DIR}" || die
+ virtualmake -C test-suite check
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${AUTOTOOLS_BUILD_DIR}/doc/api/html/." )
+ autotools-utils_src_install
+
+ use examples && \
+ insinto /usr/share/${PN} && \
+ doins -r "${WORKDIR}"/burrow-demos/*
+}
diff --git a/sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch b/sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch
new file mode 100644
index 000000000000..cca640a6347d
--- /dev/null
+++ b/sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch
@@ -0,0 +1,38 @@
+Fix build with GLIBC-2.12
+
+http://bugs.gentoo.org/show_bug.cgi?id=333843
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -82,8 +82,8 @@
+ painter.h \
+ ticket.c \
+ ticket.h \
+-endian.c \
+-endian.h \
++bo_endian.c \
++bo_endian.h \
+ version.c \
+ version.h
+
+--- src/hosbackingfile.c
++++ src/hosbackingfile.c
+@@ -18,6 +18,7 @@
+ */
+
+ #include "hosbackingfile.h"
++#include "bo_endian.h"
+
+ #define DEFAULT_BUF_SIZE 512
+
+--- src/nih.c
++++ src/nih.c
+@@ -24,7 +24,7 @@
+ #include "hosdimensionblock.h"
+ #include "hosbackingblock.h"
+ #include "hosbackingfile.h"
+-#include "endian.h"
++#include "bo_endian.h"
+
+ /* --- header contents ----
+ *
diff --git a/sci-chemistry/burrow-owl/files/1.4-include.patch b/sci-chemistry/burrow-owl/files/1.4-include.patch
new file mode 100644
index 000000000000..3dc4cbdf8000
--- /dev/null
+++ b/sci-chemistry/burrow-owl/files/1.4-include.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gw/spectrum-spec.scm b/src/gw/spectrum-spec.scm
+index 253464c..605796c 100644
+--- a/src/gw/spectrum-spec.scm
++++ b/src/gw/spectrum-spec.scm
+@@ -30,6 +30,7 @@
+ "#include <painter_gdk.h>\n"
+ "#include <burrow/nih.h>\n"
+ "#include <hosbackingsim.h>\n"
++ "#include <guile-cairo/guile-cairo-smob-types.h>\n"
+ "\n"))
+
+ ; couple of disabled sources
diff --git a/sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch b/sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch
new file mode 100644
index 000000000000..340ccd2366e5
--- /dev/null
+++ b/sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch
@@ -0,0 +1,20 @@
+ burrow/canvas/gw/Makefile.am | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/burrow/canvas/gw/Makefile.am b/burrow/canvas/gw/Makefile.am
+index da50ee3..2ed89bc 100644
+--- a/burrow/canvas/gw/Makefile.am
++++ b/burrow/canvas/gw/Makefile.am
+@@ -31,9 +31,11 @@ H2DEF=@top_srcdir@/utils/h2def.py
+ canvas.defs: $(HEADERS_1)
+ $(H2DEF) --all $(HEADERS_1) > $@
+
+-canvas-gw.c canvas-gw.h canvas-gw.scm: canvas.defs
++canvas-gw.c canvas-gw.h: canvas.defs
+ GUILE_LOAD_PATH=@srcdir@:@builddir@:@GUILE_GNOME_MODULE_DIR@:@G_WRAP_MODULE_DIR@:$$GUILE_LOAD_PATH $(GUILE) -s @srcdir@/run-g-wrap.scm
+
++BUILT_SOURCES=canvas-gw.c canvas-gw.h canvas.defs
++
+ INCLUDES=@GTK_CFLAGS@ @G_WRAP_CFLAGS@ @GUILE_GNOME_CFLAGS@ @GUILE_CAIRO_CFLAGS@ @GUILE_CFLAGS@ -I$(headers_dir) -I@top_srcdir@
+
+ moduledir=$(datadir)/guile/burrow
diff --git a/sci-chemistry/burrow-owl/metadata.xml b/sci-chemistry/burrow-owl/metadata.xml
new file mode 100644
index 000000000000..9849d77b1370
--- /dev/null
+++ b/sci-chemistry/burrow-owl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <upstream>
+ <remote-id type="sourceforge">burrow-owl</remote-id>
+ </upstream>
+</pkgmetadata>