summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/nmrglue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/nmrglue')
-rw-r--r--sci-chemistry/nmrglue/Manifest2
-rw-r--r--sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch33
-rw-r--r--sci-chemistry/nmrglue/metadata.xml29
-rw-r--r--sci-chemistry/nmrglue/nmrglue-0.4.ebuild25
-rw-r--r--sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild36
5 files changed, 125 insertions, 0 deletions
diff --git a/sci-chemistry/nmrglue/Manifest b/sci-chemistry/nmrglue/Manifest
new file mode 100644
index 000000000000..4eb824ac2a3b
--- /dev/null
+++ b/sci-chemistry/nmrglue/Manifest
@@ -0,0 +1,2 @@
+DIST nmrglue-0.4-corrected.tar.gz 128298 SHA256 85c45750aef431f2c1326a9f4856eeac4da8aedbc94c6255de6e08e3ea35f316 SHA512 c2376ba8e8f993e6e4b536d67d4a780087ac8f811b2d5a846ff8b4785b02c0a4e86956c4205f90a17c5c0a2dc620d75fb7886fbad9cca314b548e3368137eda0 WHIRLPOOL eb8a2a5064b5fa5b60d16a70cf51667daa55f1584ed9d0ca3092af4672ed2c5cef56d135e82b35c107856d338fb0893248a1719b673a4e96c1edb2fb75243d08
+DIST nmrglue-0.5.tar.gz 142604 SHA256 a05c880bd0d5f0b388156409e18a5618742f829f2532d19970d05b11bfcc6103 SHA512 2a4b94eb6bae966000bfdee4dd16f4e312568915fb5f19f59f84c6deff690703f54f76366d3f9299f7ec187192ff64f2bf62836617a424d4c5c895c67d819af2 WHIRLPOOL 78f9d094a2ab1ebc01f452717fdc1cdeccc27951195c9dd6e97069a575722acf25442009b4ccede03ad728b0767fced4a2220a8072ccc1d604a9f62e9c45af4a
diff --git a/sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch b/sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch
new file mode 100644
index 000000000000..103f5b154d0b
--- /dev/null
+++ b/sci-chemistry/nmrglue/files/nmrglue-0.5-nohyper.patch
@@ -0,0 +1,33 @@
+From ba1eee9e71623110511545c058afe2a92e139aa5 Mon Sep 17 00:00:00 2001
+From: Jonathan Helmus <jjhelmus@gmail.com>
+Date: Tue, 3 Mar 2015 19:47:05 -0600
+Subject: [PATCH] pipe_proc.py tp function correctly sets FDSIZE.
+
+Fixes issue #27
+---
+ nmrglue/process/pipe_proc.py | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/nmrglue/process/pipe_proc.py b/nmrglue/process/pipe_proc.py
+index 79b6303..8c1271c 100644
+--- a/nmrglue/process/pipe_proc.py
++++ b/nmrglue/process/pipe_proc.py
+@@ -1527,13 +1527,16 @@ def tp(dic, data, hyper=False, nohyper=False, auto=False, nohdr=False):
+ data = np.array(p.tp_hyper(data), dtype="complex64")
+ else:
+ data = p.tp(data)
+- if dic[fn2 + "QUADFLAG"] != 1 and nohyper is not True:
++ if dic[fn2 + "QUADFLAG"] != 1 and nohyper is False:
+ # unpack complex as needed
+ data = np.array(p.c2ri(data), dtype="complex64")
+
+ # update the dimentionality and order
+ dic["FDSLICECOUNT"] = data.shape[0]
+- if data.dtype == 'float32':
++ if (data.dtype == 'float32') and (nohyper is True):
++ # when nohyper is True and the new last dimension was complex
++ # prior to transposing then FDSIZE is set as if the dimension was
++ # converted to complex data, that is half the actual size.
+ dic["FDSIZE"] = data.shape[1] / 2
+ else:
+ dic["FDSIZE"] = data.shape[1]
diff --git a/sci-chemistry/nmrglue/metadata.xml b/sci-chemistry/nmrglue/metadata.xml
new file mode 100644
index 000000000000..d1c1fa8f0564
--- /dev/null
+++ b/sci-chemistry/nmrglue/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Nmrglue has the ability to read, write and convert between a number of NMR file
+formats including Agilent/Varian, Bruker, NMRPipe, Sparky, SIMPSON, Rowland NMR
+Toolkit files. The files, which are represented in Python as dictionaries of
+spectral parameters and NumPy ndarray objects, can be easily examined, modified
+and processed as desired.
+
+Nmrglue provides a number of functions for processing NMR data such as
+apodization, spectral shifting, Fourier and other transformations, baseline
+smoothing and flattening, and linear prediction modeling and extrapolation.
+In addition new processing schemes can be implemented easily using the nmrglue
+provided functions and the multitude of numerical routines provided by the NumPy
+and SciPy packages.
+
+When used in conjunction with the matplotlib (or other) python plotting library
+nmrglue can be used to create publication quality figures of NMR spectrum or
+examine data interactively.
+</longdescription>
+ <upstream>
+ <remote-id type="github">jjhelmus/nmrglue</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/nmrglue/nmrglue-0.4.ebuild b/sci-chemistry/nmrglue/nmrglue-0.4.ebuild
new file mode 100644
index 000000000000..d39fd44820ce
--- /dev/null
+++ b/sci-chemistry/nmrglue/nmrglue-0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for working with NMR data in Python"
+HOMEPAGE="http://nmrglue.com/"
+SRC_URI="https://nmrglue.googlecode.com/files/${P}-corrected.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND=""
diff --git a/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild b/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild
new file mode 100644
index 000000000000..08dd91a5ab21
--- /dev/null
+++ b/sci-chemistry/nmrglue/nmrglue-0.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for working with NMR data in Python"
+HOMEPAGE="http://nmrglue.com/"
+SRC_URI="https://github.com/jjhelmus/nmrglue/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-nohyper.patch )
+
+python_test() {
+ nosetests --verbosity=3 || die
+}