summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-06-29 00:28:09 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-06-29 00:28:09 +0300
commit37d77f4d6250277c494aa6353f3cebe49db2e900 (patch)
tree3f36016f9f55e6fdaf3de26ac234647ddab6f333 /sci-chemistry
parentapp-pda/barry: libgcal will be removed (#659532) (diff)
downloadgentoo-37d77f4d6250277c494aa6353f3cebe49db2e900.tar.gz
gentoo-37d77f4d6250277c494aa6353f3cebe49db2e900.tar.bz2
gentoo-37d77f4d6250277c494aa6353f3cebe49db2e900.zip
sci-chemistry/mdtraj: Initial import
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mdtraj/Manifest1
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild34
-rw-r--r--sci-chemistry/mdtraj/metadata.xml8
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/mdtraj/Manifest b/sci-chemistry/mdtraj/Manifest
new file mode 100644
index 000000000000..982cdea3569f
--- /dev/null
+++ b/sci-chemistry/mdtraj/Manifest
@@ -0,0 +1 @@
+DIST mdtraj-1.9.1.tar.gz 1985711 BLAKE2B 625b7c1da998bd46732604dcc93c76f970f3c79f10e81aa9f4b3051ee45101efea8afd803d539ba1831dac3e7ed208d7c3773f74189a3887063cbff2b4d79df6 SHA512 015d9d1e258a7a207ac3b7e7a81b87c308e8684ee0a173ae9b722a90910e95e7f2ee18158c163212fae39d093b0cf397293d6e713538acb1fd20a7b70f2adc76
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
new file mode 100644
index 000000000000..20033bd3da66
--- /dev/null
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
+HOMEPAGE="http://mdtraj.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
+ -i basesetup.py || die
+ distutils-r1_python_prepare_all
+} \ No newline at end of file
diff --git a/sci-chemistry/mdtraj/metadata.xml b/sci-chemistry/mdtraj/metadata.xml
new file mode 100644
index 000000000000..8425c0d53cb0
--- /dev/null
+++ b/sci-chemistry/mdtraj/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>