summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-05-06 23:13:04 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-05-06 23:13:32 +0100
commit4ec881ef10b4bcbffd3b56bc78a680b29cd59853 (patch)
tree18f8baaca6f03f595300af9f4619d4c5b5b46252 /sci-chemistry
parentdev-db/percona-toolkit: Bump to v3.0.9 (diff)
downloadgentoo-4ec881ef10b4bcbffd3b56bc78a680b29cd59853.tar.gz
gentoo-4ec881ef10b4bcbffd3b56bc78a680b29cd59853.tar.bz2
gentoo-4ec881ef10b4bcbffd3b56bc78a680b29cd59853.zip
sci-chemistry/openbabel: allow gcc-8, bug #654800
openbabel explicitly whitelists list of major GCC versions. The change by Milan allow gcc-8. Newer upstream versions fixed the code to handle in in a more generic way: https://github.com/openbabel/openbabel/commit/00120f89cf62b121c30d0b2a891b159e19b53624 Fixed-by: milan hodoscek Closes: https://bugs.gentoo.org/654800 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel/files/openbabel-2.4.1-gcc-8.patch15
-rw-r--r--sci-chemistry/openbabel/openbabel-2.4.1.ebuild3
2 files changed, 17 insertions, 1 deletions
diff --git a/sci-chemistry/openbabel/files/openbabel-2.4.1-gcc-8.patch b/sci-chemistry/openbabel/files/openbabel-2.4.1-gcc-8.patch
new file mode 100644
index 000000000000..632ffa867613
--- /dev/null
+++ b/sci-chemistry/openbabel/files/openbabel-2.4.1-gcc-8.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/654800
+Fixed-by: milan hodoscek
+diff --git a/../old/CMakeLists.txt b/CMakeLists.txt
+index dc38d1b..801207e 100644
+--- a/../old/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -239,7 +239,7 @@ check_type_size(clock_t CLOCK_T)
+ # Get the GCC version - from KDE4 cmake files
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ exec_program(${CMAKE_C_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info)
+- string(REGEX MATCH "[34567]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
++ string(REGEX MATCH "[345678]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
+ # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
+ # patch level, handle this here:
+ if (NOT _gcc_version)
diff --git a/sci-chemistry/openbabel/openbabel-2.4.1.ebuild b/sci-chemistry/openbabel/openbabel-2.4.1.ebuild
index 3719af8c81d7..4606746af57d 100644
--- a/sci-chemistry/openbabel/openbabel-2.4.1.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,6 +31,7 @@ DOCS=( AUTHORS NEWS.md README.md THANKS doc/dioxin.{inc,mol2} doc/README.{dioxin
PATCHES=(
"${FILESDIR}"/${PN}-2.3.2-gcc-6_and_7-backport.patch
+ "${FILESDIR}"/${P}-gcc-8.patch
)
pkg_setup() {