summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-14 00:53:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-14 10:42:42 +0100
commit63b820bd77d76e5aa5a1a50717716d11c0c84bc3 (patch)
tree62d9b9b88850a02c50c734116472b9ebed9163dd /sci-chemistry
parentapp-misc/cbview: Update homepage (diff)
downloadgentoo-63b820bd77d76e5aa5a1a50717716d11c0c84bc3.tar.gz
gentoo-63b820bd77d76e5aa5a1a50717716d11c0c84bc3.tar.bz2
gentoo-63b820bd77d76e5aa5a1a50717716d11c0c84bc3.zip
sci-chemistry/avogadro: Fix cmake w/ >=GCC-6
Using the upstream patch, even if it is not the proper solution. Closes: https://bugs.gentoo.org/619544 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/avogadro/avogadro-1.1.1.ebuild3
-rw-r--r--sci-chemistry/avogadro/files/avogadro-1.1.1-gcc-version.patch23
2 files changed, 25 insertions, 1 deletions
diff --git a/sci-chemistry/avogadro/avogadro-1.1.1.ebuild b/sci-chemistry/avogadro/avogadro-1.1.1.ebuild
index 5e9225721e1d..63150ada5fa9 100644
--- a/sci-chemistry/avogadro/avogadro-1.1.1.ebuild
+++ b/sci-chemistry/avogadro/avogadro-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -45,6 +45,7 @@ PATCHES=(
"${FILESDIR}"/${P}-pkgconfig_eigen.patch
"${FILESDIR}"/${P}-openbabel.patch
"${FILESDIR}"/${P}-boost-join-moc.patch
+ "${FILESDIR}"/${P}-gcc-version.patch
)
pkg_setup() {
diff --git a/sci-chemistry/avogadro/files/avogadro-1.1.1-gcc-version.patch b/sci-chemistry/avogadro/files/avogadro-1.1.1-gcc-version.patch
new file mode 100644
index 000000000000..48840204a8a0
--- /dev/null
+++ b/sci-chemistry/avogadro/files/avogadro-1.1.1-gcc-version.patch
@@ -0,0 +1,23 @@
+From a8bf7bcd7881147c3bcec97d247a2fa4160019d9 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Tue, 5 Jul 2016 00:10:26 +0200
+Subject: [PATCH] Fix detection of gcc6's version number
+
+...and be safe for further new versions.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1cbeb8f10..8d2958739 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -69,7 +69,7 @@ if (CMAKE_COMPILER_IS_GNUCXX)
+ # Now check if we can use visibility to selectively export symbols
+ # Get the GCC version - from KDE4 cmake files
+ exec_program(${CMAKE_C_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info)
+- string (REGEX MATCH "[345]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
++ string (REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
+ # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
+ # patch level, handle this here:
+ if (NOT _gcc_version)