summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-04-08 12:52:06 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-04-08 12:52:06 +0300
commit7ed232b26caa687abd38b7079d9f4e19a86a3bc3 (patch)
tree516fb0c54dd572c93b1c83ae09e424ef2218db81 /sci-chemistry
parentdev-ruby/httpclient: update EAPI 5 -> 8 (diff)
downloadgentoo-7ed232b26caa687abd38b7079d9f4e19a86a3bc3.tar.gz
gentoo-7ed232b26caa687abd38b7079d9f4e19a86a3bc3.tar.bz2
gentoo-7ed232b26caa687abd38b7079d9f4e19a86a3bc3.zip
sci-chemistry/pymol: enable py3.10
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol/pymol-2.5.0.ebuild20
1 files changed, 3 insertions, 17 deletions
diff --git a/sci-chemistry/pymol/pymol-2.5.0.ebuild b/sci-chemistry/pymol/pymol-2.5.0.ebuild
index a7fc5fdc127c..93464f4a28be 100644
--- a/sci-chemistry/pymol/pymol-2.5.0.ebuild
+++ b/sci-chemistry/pymol/pymol-2.5.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
DISTUTILS_USE_SETUPTOOLS=no
-inherit desktop optfeature flag-o-matic xdg distutils-r1
+inherit desktop flag-o-matic xdg distutils-r1
DESCRIPTION="A Python-extensible molecular graphics system"
HOMEPAGE="https://www.pymol.org/"
@@ -65,15 +65,6 @@ python_prepare_all() {
python_install() {
distutils-r1_python_install \
--pymol-path="${EPREFIX}/usr/share/pymol"
-
-# File is not created as apbs was dropped from the tree
-# https://bugs.gentoo.org/790629
-# sed \
-# -e '1d' \
-# -e "/APBS_BINARY_LOCATION/s:None:\"${EPREFIX}/usr/bin/apbs\":g" \
-# -e "/APBS_PSIZE_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/src/\":g" \
-# -e "/APBS_PDB2PQR_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/\":g" \
-# -i "${D}/$(python_get_sitedir)"/pmg_tk/startup/apbs_tools.py || die
}
python_install_all() {
@@ -106,8 +97,3 @@ python_install_all() {
rm -f "${ED}"/usr/share/${PN}/LICENSE || die
}
-
-#pkg_postinst() {
-# xdg_pkg_postinst
-# optfeature "Electrostatic calculations" sci-chemistry/apbs sci-chemistry/pdb2pqr
-#}