summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-03-08 17:02:29 +0100
committerPacho Ramos <pacho@gentoo.org>2021-03-08 17:02:29 +0100
commitad2a1ba9cb8604ea107ba8dfeb5f44e3a720396c (patch)
treea38be3333d59755afab07bf7c4145b8ed61419b5 /sci-chemistry
parentnet-wireless/bluez: Bump to 5.56 (diff)
downloadgentoo-ad2a1ba9cb8604ea107ba8dfeb5f44e3a720396c.tar.gz
gentoo-ad2a1ba9cb8604ea107ba8dfeb5f44e3a720396c.tar.bz2
gentoo-ad2a1ba9cb8604ea107ba8dfeb5f44e3a720396c.zip
sci-chemistry/chemex: Support python 3.9, fix tests
Closes: https://bugs.gentoo.org/738242 Thanks-to: Agostino Sarubbo Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/chemex/chemex-2018.10.3.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sci-chemistry/chemex/chemex-2018.10.3.ebuild b/sci-chemistry/chemex/chemex-2018.10.3.ebuild
index fc6cc2f0ca18..0c983b2eb24f 100644
--- a/sci-chemistry/chemex/chemex-2018.10.3.ebuild
+++ b/sci-chemistry/chemex/chemex-2018.10.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_SINGLE_IMPL="yes"
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -30,13 +30,11 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+distutils_enable_tests pytest
+
S="${WORKDIR}/ChemEx-${PV}"
src_prepare() {
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
distutils-r1_src_prepare
}
-
-python_test() {
- py.test -v -v || die
-}