summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 18:38:32 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 18:56:56 +0100
commitc8634824ffa219f0cb5c35f09ed5fe765d19b163 (patch)
treed86bddd98e05c8f81479ee75116bc03ed3cb86ac /sci-chemistry
parentapp-office/wps-office: Drop old (diff)
downloadgentoo-c8634824ffa219f0cb5c35f09ed5fe765d19b163.tar.gz
gentoo-c8634824ffa219f0cb5c35f09ed5fe765d19b163.tar.bz2
gentoo-c8634824ffa219f0cb5c35f09ed5fe765d19b163.zip
sci-chemistry/chemex: Version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/chemex/Manifest1
-rw-r--r--sci-chemistry/chemex/chemex-2021.4.0_p6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index 594cc24b8683..768d0a6c15a7 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,2 +1,3 @@
DIST chemex-2021.4.0_p2.tar.gz 2384471 BLAKE2B 1eb609c4e4ad9ac0f7cac8ab523e72e8ab9c12d40671fd598cd26b8de2a3d6e68dfdcaee9202521fc583068f591377842b3e7b9f0e1f95e6cba8da9b0c6d63a4 SHA512 568072eaf0d1c666de2aedacc50cd98da15631e0ef15ba60414be671ac97a50967e5b4d6d00340b1263f730b3a803ccc8995fbb86cfc47517b9521c9920641c8
DIST chemex-2021.4.0_p4.tar.gz 2387888 BLAKE2B 26b4467756ba1b31775c554906a2ce09556e1fb99dd2ff294620a12b92246f441a2daa07e6bad7cedf903bd18e6ecc0613b6473f54d27d89ed9117ddc6a27269 SHA512 7d93f213317e4cb5a987c0b3cfcce146fb02a15ac9efbde74f9d3fc56a5e86c89ca6b606f45013bf08ed10f3de17cc72fa010ce0e42c5cb746119ede0ce4d38f
+DIST chemex-2021.4.0_p6.tar.gz 2395324 BLAKE2B adb08fdebe816b66359c8a567d7f7a4600715015e6f9b86b568cb8e3cd5e66b040895c09688a956cedd398a7c56a6d3a73d77f647a2f4e83280a91879a6184d0 SHA512 7d20ae73a2cf52f9d21b875cd661cefc14ce36ff603402e5dacad3e21bcb0bdb28f8f111414691b99f93196a971215d0beec3fff07535d3d781b4e7bb6782c52
diff --git a/sci-chemistry/chemex/chemex-2021.4.0_p6.ebuild b/sci-chemistry/chemex/chemex-2021.4.0_p6.ebuild
new file mode 100644
index 000000000000..3a331d48eba7
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2021.4.0_p6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until we figure out how to run tests properly, bug #815079
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/asteval-0.9.25[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.4.3[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21.2[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.61.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}