summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-10 16:00:43 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-10 16:00:55 +0100
commitca4803f9e53d7108d632e78f91265e72ade4c9be (patch)
treefd159960d7ce4b9b72fac03918d2eeb7f8b69a82 /sci-chemistry
parentnet-mail/mailutils: add kyotocabinet support (#545362) (diff)
downloadgentoo-ca4803f9e53d7108d632e78f91265e72ade4c9be.tar.gz
gentoo-ca4803f9e53d7108d632e78f91265e72ade4c9be.tar.bz2
gentoo-ca4803f9e53d7108d632e78f91265e72ade4c9be.zip
sci-chemistry/pymol-plugins-emovie: Bump to EAPI=5 and python-r1.eclass
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=567928 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-plugins-emovie/metadata.xml6
-rw-r--r--sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild46
2 files changed, 17 insertions, 35 deletions
diff --git a/sci-chemistry/pymol-plugins-emovie/metadata.xml b/sci-chemistry/pymol-plugins-emovie/metadata.xml
index 18330bb401f1..1837bbc07a6e 100644
--- a/sci-chemistry/pymol-plugins-emovie/metadata.xml
+++ b/sci-chemistry/pymol-plugins-emovie/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild b/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
index 38a48fd485fe..667dcf30bf1d 100644
--- a/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
+++ b/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
+EAPI=5
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python2_7 )
-inherit eutils python
+inherit eutils python-r1
-DESCRIPTION="eMovie is a plug-in tool for the molecular visualization program PyMOL"
+DESCRIPTION="PyMOL plugin for convinient movie creation"
SRC_URI="http://www.weizmann.ac.il/ISPC/eMovie_package.zip"
HOMEPAGE="http://www.weizmann.ac.il/ISPC/eMovie.html"
@@ -17,38 +17,20 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64 ~x86-linux ~amd64-linux"
IUSE=""
-RDEPEND=">sci-chemistry/pymol-0.99"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >sci-chemistry/pymol-0.99[${PYTHON_USEDEP}]"
DEPEND="app-arch/unzip"
-#RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}"
src_prepare() {
epatch "${FILESDIR}"/${PV}-indent.patch
-
- mkdir ${P}
- mv e* ${P}/
-
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w eMovie.py > /dev/null
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
}
src_install(){
- installation() {
- insinto $(python_get_sitedir)/pmg_tk/startup/
- doins eMovie.py || die
- }
- python_execute_function -s installation
-}
-
-pkg_postinst(){
- python_mod_optimize pmg_tk/startup
-}
-
-pkg_postrm() {
- python_mod_cleanup pmg_tk/startup
+ python_moduleinto pmg_tk/startup
+ python_foreach_impl python_domodule eMovie.py
+ python_foreach_impl python_optimize
}