summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/gnetman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/gnetman')
-rw-r--r--sci-electronics/gnetman/Manifest1
-rw-r--r--sci-electronics/gnetman/files/gnetman-0.0.1_pre20110124-tcl86.patch20
-rw-r--r--sci-electronics/gnetman/gnetman-0.0.1_pre20110124.ebuild50
-rw-r--r--sci-electronics/gnetman/metadata.xml14
4 files changed, 85 insertions, 0 deletions
diff --git a/sci-electronics/gnetman/Manifest b/sci-electronics/gnetman/Manifest
new file mode 100644
index 000000000000..5181ceee81ad
--- /dev/null
+++ b/sci-electronics/gnetman/Manifest
@@ -0,0 +1 @@
+DIST gnetman-0.0.1_pre20110124.tar.gz 500308 SHA256 ee1d5ac7165813405ee1c31fe6058c0b22b796decd14c0f1af27bf76fef5103d SHA512 d872bf3d4967c201a16e6b625a2003771bb7b33e8af3127a06f445429f575d32451e4ce3cc0f34389cc047b2d0cf2e3ef8afff63b1bf362184e2a5859bbb09f2 WHIRLPOOL 69807934df4e6f52f777ae426cd5258e2d2bed3d9ca25fd144b55c701bcb0f8143df50f3bd92f6668f22bc1e65198d21f6d8272548d391a73504155e9b5561aa
diff --git a/sci-electronics/gnetman/files/gnetman-0.0.1_pre20110124-tcl86.patch b/sci-electronics/gnetman/files/gnetman-0.0.1_pre20110124-tcl86.patch
new file mode 100644
index 000000000000..fdb6573990f4
--- /dev/null
+++ b/sci-electronics/gnetman/files/gnetman-0.0.1_pre20110124-tcl86.patch
@@ -0,0 +1,20 @@
+--- gnetman-0.0.1_pre20110124_orig/src/tcl/tclwrap.c 2012-05-25 07:44:51.000000000 +0200
++++ gnetman-0.0.1_pre20110124/src/tcl/tclwrap.c 2013-02-24 12:58:51.000000000 +0100
+@@ -46,7 +46,7 @@
+ result = Tcl_EvalFile(interp, (char *)fileName) == TCL_OK;
+ if (!result) {
+ utWarning("Tcl error in file %s, line %d: %s", fileName,
+- interp->errorLine, interp->result);
++ Tcl_GetErrorLine(interp), Tcl_GetStringResult(interp));
+ }
+ return result;
+ }
+@@ -75,7 +75,7 @@
+ commandLine[xChar] = '\0';
+ result = Tcl_Eval(interp, commandLine);
+ if (result == TCL_ERROR) {
+- utWarning("Tcl error: %s", interp->result);
++ utWarning("Tcl error: %s", Tcl_GetStringResult(interp));
+ }
+ } while (result != TCL_RETURN);
+ return true;
diff --git a/sci-electronics/gnetman/gnetman-0.0.1_pre20110124.ebuild b/sci-electronics/gnetman/gnetman-0.0.1_pre20110124.ebuild
new file mode 100644
index 000000000000..22b771d16789
--- /dev/null
+++ b/sci-electronics/gnetman/gnetman-0.0.1_pre20110124.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GNU Netlist Manipulation Library"
+HOMEPAGE="http://sourceforge.net/projects/gnetman/"
+#snapshot from http://gnetman.git.sourceforge.net/git/gitweb.cgi?p=gnetman/gnetman;
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc examples"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${P}/src/batch
+
+RDEPEND="dev-lang/tcl:0
+ sci-electronics/geda"
+DEPEND="${RDEPEND}
+ dev-db/datadraw"
+
+src_prepare() {
+ sed -e "/^CFLAGS=/s:-g -Wall:${CFLAGS}:" \
+ -e "/^CFLAGS=/s:-I/usr/include/tcl8.4::" \
+ -e "/^LIBS=/s:-ltcl8.4:-ltcl:" \
+ -e '/^$(TARGET):/,+3s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ -i configure || die
+ tc-export CC
+
+ cd ../.. || die
+ # fix build issues with tcl-8.6, #452034
+ epatch "${FILESDIR}/${P}-tcl86.patch"
+}
+
+src_install () {
+ cd ../.. || die
+
+ dobin bin/${PN}
+
+ insinto /usr/share/gEDA
+ doins system-gnetmanrc.tcl
+
+ use examples && dodoc -r sym sch test
+ dodoc README
+ use doc && dodoc doc/*.{html,jpg}
+}
diff --git a/sci-electronics/gnetman/metadata.xml b/sci-electronics/gnetman/metadata.xml
new file mode 100644
index 000000000000..39d0266c593e
--- /dev/null
+++ b/sci-electronics/gnetman/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ The gnetman project has one simple goal: Enabling interoperability between
+ open-source EDA tools. To date, gnetman can read and/or write (in theory)
+ formats used by the following tools :
+ * gschem
+ * iverilog
+ * ltspice, hspice, eldo, gnucap, tclspice
+ * confluence
+ </longdescription>
+</pkgmetadata>