summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2020-08-30 09:14:42 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2020-08-30 09:15:37 +0200
commitadc1e8ec9c58fdb797df8d1ae25dc94aa9587415 (patch)
tree8db5b5eb200db989f97d53661bee2d52cd751e44 /sci-electronics
parentdev-cpp/yaml-cpp: security cleanup (diff)
downloadgentoo-adc1e8ec9c58fdb797df8d1ae25dc94aa9587415.tar.gz
gentoo-adc1e8ec9c58fdb797df8d1ae25dc94aa9587415.tar.bz2
gentoo-adc1e8ec9c58fdb797df8d1ae25dc94aa9587415.zip
sci-electronics/xnec2c: Bump EAPI, fix QA problems
use docinto and dodoc instead of dohtml and insinto Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/xnec2c/xnec2c-3.5.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-electronics/xnec2c/xnec2c-3.5.1.ebuild b/sci-electronics/xnec2c/xnec2c-3.5.1.ebuild
index 8bcf439db3cf..134ddca07cc1 100644
--- a/sci-electronics/xnec2c/xnec2c-3.5.1.ebuild
+++ b/sci-electronics/xnec2c/xnec2c-3.5.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools eutils
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
src_prepare() {
+ eapply_user
+
glib-gettextize --force --copy || die
eautoreconf
}
@@ -28,7 +30,7 @@ src_install() {
default
dodoc AUTHORS README doc/*.txt
- use doc && dohtml -r doc/*.html doc/images
- insinto /usr/share/doc/${PF}/examples
- use examples && doins examples/*
+ use doc && dodoc -r doc/*.html doc/images
+ docinto examples
+ use examples && dodoc examples/*
}