summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-30 12:46:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-30 13:03:43 +0200
commitb9b83cc6a5398e3ece64187da5b708c24b5606f2 (patch)
tree85fea9e3cbc237d236c604ad74d7ea3f28557911 /sci-electronics
parentsci-physics/geant-data: fix manifest of G4RealSurface.2.1.1.tar.gz (diff)
downloadgentoo-b9b83cc6a5398e3ece64187da5b708c24b5606f2.tar.gz
gentoo-b9b83cc6a5398e3ece64187da5b708c24b5606f2.tar.bz2
gentoo-b9b83cc6a5398e3ece64187da5b708c24b5606f2.zip
sci-electronics/librepcb: Drop unused dependency
Closes: https://bugs.gentoo.org/687842 Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/librepcb/librepcb-0.1.0-r1.ebuild36
-rw-r--r--sci-electronics/librepcb/librepcb-9999.ebuild1
2 files changed, 36 insertions, 1 deletions
diff --git a/sci-electronics/librepcb/librepcb-0.1.0-r1.ebuild b/sci-electronics/librepcb/librepcb-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..4a304ef6f48f
--- /dev/null
+++ b/sci-electronics/librepcb/librepcb-0.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Free EDA software to develop printed circuit boards"
+HOMEPAGE="https://librepcb.org/"
+SRC_URI="https://download.librepcb.org/releases/${PV}/${P}-source.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 -r PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
diff --git a/sci-electronics/librepcb/librepcb-9999.ebuild b/sci-electronics/librepcb/librepcb-9999.ebuild
index 433dfcae1aa2..9f9a585fcd61 100644
--- a/sci-electronics/librepcb/librepcb-9999.ebuild
+++ b/sci-electronics/librepcb/librepcb-9999.ebuild
@@ -22,7 +22,6 @@ RDEPEND="
dev-qt/qtprintsupport:5
dev-qt/qtsql:5
dev-qt/qtwidgets:5
- dev-qt/qtwebkit:5
dev-qt/qtxml:5
sys-libs/zlib"