summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-21 17:37:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-22 11:31:56 +0200
commitb9e4e2a2583586bda7164c83fdb6aa6235cfe8cf (patch)
treef58c04e15de00c7e335596dd373c7aec9f2c535d /sci-electronics
parentros-meta/bond_core: Bump to 1.8.3. (diff)
downloadgentoo-b9e4e2a2583586bda7164c83fdb6aa6235cfe8cf.tar.gz
gentoo-b9e4e2a2583586bda7164c83fdb6aa6235cfe8cf.tar.bz2
gentoo-b9e4e2a2583586bda7164c83fdb6aa6235cfe8cf.zip
sci-electronics/gazebo: bump to 9.3.0
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/gazebo-9.3.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index 71b40029b9ca..3b725786ddac 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1,3 +1,4 @@
DIST gazebo-9.0.0.tar.bz2 52779811 BLAKE2B a85c9fd0e4b805e28ea8fb71c068ad53f18db91a474631b5da73a2a565181c8c22270742c9fabf1656d322fd63ba1caac3286b992d7dc7b197a0582ed724d06e SHA512 52394445d34ce24b2036102be08b6b626fb7021dd0ebaab8e588b68e1e0790d2e26ed2af8ead8f37b0c2e2d37c3d7fc22f95b0b2a8bd95e8dcd77e7fb296dd50
DIST gazebo-9.1.1.tar.bz2 52978923 BLAKE2B 46ddcc0928b3f591356379e20fa5478e385046f8ef2295730b5cb69e07636928226e423db654697a32bcab14846cd13dfe6248017fe1f410d4060f372154ae69 SHA512 1892a3f09d98b75cfdd30b020eb335b4e267db161850eba58153c5be4beb1c2053843f336d63fe638e3ba6466a9d746210a8e7cf3e2d577cc380ce4904576b3c
DIST gazebo-9.2.0.tar.bz2 52929158 BLAKE2B 208b911551d4a16f5ab2e37b033e0f132bfbf4cdf01129fa4849d67ea9d2e092e00c3382e925a437d67916ddbaaf8ac499b21231ebdc5bd2302865476b9773df SHA512 4c91c66ce4b5d63cb97d948de5f9d5ae9dcb88de8f5e650a6f6dee085cd7539454a25871691a1bdb38a3c65fa52c5ea1b94fbd3a618a77cb234579f2f268a017
+DIST gazebo-9.3.0.tar.bz2 52924750 BLAKE2B c908827fca7786b0dac10401549265d6d0ca0ce5c952816b5d3d5f2feec096f0465778b4165a4054abd285ec1fedc80e3d2ed3c81be234574d7419d2635f61f4 SHA512 5874582e015cfc2b690b26cd810e4c79cc5dba1ecea7eaa72d3c12e0a5f3dd6f42185666f0cf36a1d00564b642c2c63662b06657da82cfd2ce3ebd9219012cb4
diff --git a/sci-electronics/gazebo/gazebo-9.3.0.ebuild b/sci-electronics/gazebo/gazebo-9.3.0.ebuild
new file mode 100644
index 000000000000..a1bfd2b1d31f
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-9.3.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/9"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ >=dev-libs/tinyxml2-6:=
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4:=[freeimage]
+ <dev-games/ogre-1.10
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ libav? ( >=media-video/libav-9:0= )
+ !libav? ( >=media-video/ffmpeg-2.6:0= )
+ sci-libs/gts
+ >=sci-physics/bullet-2.82
+ >=dev-libs/sdformat-6.0:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=[threads]
+ sci-libs/gdal:=
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ media-gfx/graphviz
+ net-libs/ignition-msgs:1=
+ sci-libs/ignition-math:4=
+ net-libs/ignition-transport:4=
+ x11-libs/qwt:6=[qt5(+)]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ app-text/ronn
+ app-arch/gzip
+ virtual/pkgconfig
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/qwt.patch" )
+
+src_configure() {
+ # doesnt build without it
+ append-cxxflags "-std=c++11"
+ # doesnt build with as-needed either
+ append-ldflags "-Wl,--no-as-needed"
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake-utils_src_configure
+}