summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-19 00:50:20 +0100
committerSam James <sam@gentoo.org>2021-06-19 01:03:41 +0100
commitee1db344d0746f7f1e340777a5698acd6491109b (patch)
treebc209d46f3eefdd6dd130eb87a90090b6e392069 /sci-geosciences/qgis
parentsci-geosciences/qgis: fixes for paths, adds PDAL option (diff)
downloadgentoo-ee1db344d0746f7f1e340777a5698acd6491109b.tar.gz
gentoo-ee1db344d0746f7f1e340777a5698acd6491109b.tar.bz2
gentoo-ee1db344d0746f7f1e340777a5698acd6491109b.zip
sci-geosciences/qgis: add 3.20.0, adjust live
* Drop USE=webkit (adds a deprecated dependency on qtwebkit) * Restore zlib dependency Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/qgis')
-rw-r--r--sci-geosciences/qgis/Manifest1
-rw-r--r--sci-geosciences/qgis/qgis-3.20.0.ebuild202
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild10
3 files changed, 208 insertions, 5 deletions
diff --git a/sci-geosciences/qgis/Manifest b/sci-geosciences/qgis/Manifest
index bdaa699fbd85..05d84be13d3d 100644
--- a/sci-geosciences/qgis/Manifest
+++ b/sci-geosciences/qgis/Manifest
@@ -2,4 +2,5 @@ DIST qgis-3.16.2.tar.bz2 114086615 BLAKE2B 85196072b792b5731dcbc85cfaaae1768e91d
DIST qgis-3.16.4.tar.bz2 115427023 BLAKE2B 1526350974b634d13f55b77e99ec54c8cd29eb523657657f72de0f9e9b2b47d931e503404b202fe2e181c8e1918888732cc4353091dd8dffcaefb6caa32ad47f SHA512 a58ef90089416ac08ba014f483cf7f6f929ef97306e213a5d1855fe551ecc42631926f8e015134ebcbc368f134c9f3ed8f2fda1846a409f249ed00b104036d25
DIST qgis-3.16.8.tar.bz2 116478775 BLAKE2B b4a310745ec24a41471073c390063e4aae2d58001dae18b8ea1f1b7f430e7380ae541c3fb7efc05a7bafe617f3bcc0b1f123654941622ee6d1d29cde40acc301 SHA512 4b4941c78a4eebf0ad2d6eaebdcd15cd1fa0a4435b4043b2c23bf388b9dc2e4ad0211cf9921e8c3b336bc94e619842ea9b21fe42ca4084e8c1bc889586f86db7
DIST qgis-3.18.3.tar.bz2 121178524 BLAKE2B 9f4c5bb4b4bf980c81b91a38716b280f48bf28d894550563607e202a7764f72c78b9520f060319c219e484254eaa31315fc232b459bec8cc6a1bc07b587babc6 SHA512 d2c08f1f0bdb2ba56a108dc9626122dfe90caae4f300ceb7be2d40112ee9bcc7f286f092f7f207812428aca926c7fe0dabe49039bba0f32f2f371d290536f0ef
+DIST qgis-3.20.0.tar.bz2 131619071 BLAKE2B c6644b6e858a38c5b15846d39293d5b92b849efb44d147b8968a5630db413b427150f20722a24e806a14af877b88c0b06774777fd01dd8753cd9305ba1c40e33 SHA512 0f1d9527d3cf4241ed7688fe4f13e459beb7848c99492a995ac30d8b0c874f3198007d25d9fbde51cc36e6e08029a2fdd2d023c88423adb925a0a99778df27bc
DIST qgis_sample_data-2.8.14.tar.gz 22119181 BLAKE2B 2d0565e91ec8119382bc9ab8e262dc04227fe8289146794891759ff5a32012245270614ba1119a6329fc45cf56852830c2079589309aa3467873f71f5c608eac SHA512 6b2653d5b57ffc2c2317639dac212429840984ac917ca3e452b39aabb99ea106d1a77c1c1dd967244ef16ede9deae751b170affdf08b72239eafed5b8977da3d
diff --git a/sci-geosciences/qgis/qgis-3.20.0.ebuild b/sci-geosciences/qgis/qgis-3.20.0.ebuild
new file mode 100644
index 000000000000..389d43b14941
--- /dev/null
+++ b/sci-geosciences/qgis/qgis-3.20.0.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite"
+QT_MIN_VER="5.9.4"
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN^^}.git"
+ inherit git-r3
+else
+ SRC_URI="https://qgis.org/downloads/${P}.tar.bz2
+ examples? ( https://qgis.org/downloads/data/qgis_sample_data.tar.gz -> qgis_sample_data-2.8.14.tar.gz )"
+ KEYWORDS="~amd64 ~x86"
+fi
+inherit cmake desktop python-single-r1 qmake-utils xdg
+
+DESCRIPTION="User friendly Geographic Information System"
+HOMEPAGE="https://www.qgis.org/"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-qt/linguist-tools-${QT_MIN_VER}:5
+ sys-devel/bison
+ sys-devel/flex
+"
+COMMON_DEPEND="
+ app-crypt/qca:2[qt5(+),ssl]
+ >=dev-db/spatialite-4.2.0
+ dev-db/sqlite:3
+ dev-libs/expat
+ dev-libs/libzip:=
+ dev-libs/qtkeychain[qt5(+)]
+ >=dev-qt/designer-${QT_MIN_VER}:5
+ >=dev-qt/qtconcurrent-${QT_MIN_VER}:5
+ >=dev-qt/qtcore-${QT_MIN_VER}:5
+ >=dev-qt/qtgui-${QT_MIN_VER}:5
+ >=dev-qt/qtnetwork-${QT_MIN_VER}:5[ssl]
+ >=dev-qt/qtpositioning-${QT_MIN_VER}:5
+ >=dev-qt/qtprintsupport-${QT_MIN_VER}:5
+ >=dev-qt/qtserialport-${QT_MIN_VER}:5
+ >=dev-qt/qtsvg-${QT_MIN_VER}:5
+ >=dev-qt/qtsql-${QT_MIN_VER}:5
+ >=dev-qt/qtwidgets-${QT_MIN_VER}:5
+ >=dev-qt/qtxml-${QT_MIN_VER}:5
+ media-gfx/exiv2:=
+ >=sci-libs/gdal-3.0.4:=[geos]
+ sci-libs/geos
+ sci-libs/libspatialindex:=
+ sys-libs/zlib
+ >=sci-libs/proj-4.9.3:=
+ >=x11-libs/qscintilla-2.10.1:=[qt5(+)]
+ >=x11-libs/qwt-6.1.2:6=[qt5(+),svg]
+ 3d? ( >=dev-qt/qt3d-${QT_MIN_VER}:5 )
+ georeferencer? ( sci-libs/gsl:= )
+ grass? ( =sci-geosciences/grass-7*:= )
+ hdf5? ( sci-libs/hdf5:= )
+ mapserver? ( dev-libs/fcgi )
+ netcdf? ( sci-libs/netcdf:= )
+ opencl? ( virtual/opencl )
+ oracle? (
+ dev-db/oracle-instantclient:=
+ sci-libs/gdal:=[oracle]
+ )
+ polar? ( >=x11-libs/qwtpolar-1.1.1-r1[qt5(+)] )
+ postgres? ( dev-db/postgresql:= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/jinja[${PYTHON_MULTI_USEDEP}]
+ dev-python/markupsafe[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/owslib[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[designer,network,sql,svg,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytz[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ <dev-python/sip-5:=[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/gdal-2.2.3[python,${PYTHON_MULTI_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}] )
+ ')
+ )
+ qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/qttest-${QT_MIN_VER}:5
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${COMMON_DEPEND}
+ sci-geosciences/gpsbabel
+"
+
+# Disabling test suite because upstream disallow running from install path
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DQGIS_MANUAL_SUBDIR=share/man/
+ -DQGIS_LIB_SUBDIR=$(get_libdir)
+ -DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis
+ -DQWT_INCLUDE_DIR=/usr/include/qwt6
+ -DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt5.so
+ -DPEDANTIC=OFF
+ -DUSE_CCACHE=OFF
+ -DWITH_ANALYSIS=ON
+ -DWITH_APIDOC=OFF
+ -DWITH_GUI=ON
+ -DWITH_INTERNAL_MDAL=ON # not packaged, bug 684538
+ -DWITH_QSPATIALITE=ON
+ -DENABLE_TESTS=OFF
+ -DWITH_3D=$(usex 3d)
+ -DWITH_GEOREFERENCER=$(usex georeferencer)
+ -DWITH_GRASS7=$(usex grass)
+ $(cmake_use_find_package hdf5 HDF5)
+ -DWITH_SERVER=$(usex mapserver)
+ $(cmake_use_find_package netcdf NetCDF)
+ -DUSE_OPENCL=$(usex opencl)
+ -DWITH_ORACLE=$(usex oracle)
+ -DWITH_QWTPOLAR=$(usex polar)
+ -DWITH_POSTGRESQL=$(usex postgres)
+ -DWITH_BINDINGS=$(usex python)
+ -DWITH_CUSTOM_WIDGETS=$(usex python)
+ -DWITH_QUICK=$(usex qml)
+ -DWITH_QTWEBKIT=OFF
+ )
+
+ if use grass; then
+ readarray -d'-' -t f <<<"$(best_version sci-geosciences/grass)"
+ readarray -d'.' -t v <<<"${f[2]}"
+ grassdir="grass${v[0]}${v[1]}"
+
+ GRASSDIR=/usr/$(get_libdir)/${grassdir}
+ mycmakeargs+=( -DGRASS_PREFIX7=${GRASSDIR} )
+ fi
+
+ use python && mycmakeargs+=( -DBINDINGS_GLOBAL_INSTALL=ON )
+
+ # bugs 612956, 648726
+ addpredict /dev/dri/renderD128
+ addpredict /dev/dri/renderD129
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /usr/share/mime/packages
+ doins debian/qgis.xml
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${WORKDIR}"/qgis_sample_data/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use python; then
+ python_optimize
+ python_optimize "${ED}"/usr/share/qgis/python
+ fi
+
+ if use grass; then
+ python_fix_shebang "${ED}"/usr/share/qgis/grass/scripts
+ fi
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "If you don't intend to use an external PostGIS server"
+ elog "you should install:"
+ elog " dev-db/postgis"
+ elif use python; then
+ elog "Support of PostgreSQL is disabled."
+ elog "But some installed python-plugins import the psycopg2 module."
+ elog "If you do not need these plugins just disable them"
+ elog "in the Plugins menu, else you need to set USE=\"postgres\""
+ fi
+
+ xdg_pkg_postinst
+}
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index 60ed73da843c..389d43b14941 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="sqlite"
QT_MIN_VER="5.9.4"
@@ -22,7 +22,7 @@ HOMEPAGE="https://www.qgis.org/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml webkit"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -55,6 +55,7 @@ COMMON_DEPEND="
>=sci-libs/gdal-3.0.4:=[geos]
sci-libs/geos
sci-libs/libspatialindex:=
+ sys-libs/zlib
>=sci-libs/proj-4.9.3:=
>=x11-libs/qscintilla-2.10.1:=[qt5(+)]
>=x11-libs/qwt-6.1.2:6=[qt5(+),svg]
@@ -81,7 +82,7 @@ COMMON_DEPEND="
dev-python/numpy[${PYTHON_MULTI_USEDEP}]
dev-python/owslib[${PYTHON_MULTI_USEDEP}]
dev-python/pygments[${PYTHON_MULTI_USEDEP}]
- dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[designer,network,sql,svg,${PYTHON_MULTI_USEDEP}]
dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
dev-python/pytz[${PYTHON_MULTI_USEDEP}]
dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
@@ -94,7 +95,6 @@ COMMON_DEPEND="
')
)
qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
- webkit? ( >=dev-qt/qtwebkit-5.212.0_pre20200309-r1:5 )
"
DEPEND="${COMMON_DEPEND}
>=dev-qt/qttest-${QT_MIN_VER}:5
@@ -143,7 +143,7 @@ src_configure() {
-DWITH_BINDINGS=$(usex python)
-DWITH_CUSTOM_WIDGETS=$(usex python)
-DWITH_QUICK=$(usex qml)
- -DWITH_QTWEBKIT=$(usex webkit)
+ -DWITH_QTWEBKIT=OFF
)
if use grass; then