summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-05-06 18:25:51 +0200
committerAndrey Grozin <grozin@gentoo.org>2019-05-06 18:25:51 +0200
commit097b001971d868419e74df096a0e6989e3e1b63e (patch)
tree54d7c73b628f476abc825a0c726689d2c3611956 /sci-geosciences/qmapshack
parentsci-libs/gdal: bump to 2.4.1 (diff)
downloadgentoo-097b001971d868419e74df096a0e6989e3e1b63e.tar.gz
gentoo-097b001971d868419e74df096a0e6989e3e1b63e.tar.bz2
gentoo-097b001971d868419e74df096a0e6989e3e1b63e.zip
sci-geosciences/qmapshack: bump to 1.13.0
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences/qmapshack')
-rw-r--r--sci-geosciences/qmapshack/Manifest1
-rw-r--r--sci-geosciences/qmapshack/files/FindPROJ4.cmake152
-rw-r--r--sci-geosciences/qmapshack/files/qmapshack-positioning.patch9
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.13.0.ebuild49
4 files changed, 211 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/Manifest b/sci-geosciences/qmapshack/Manifest
index f38aefce0f41..11b1647491a8 100644
--- a/sci-geosciences/qmapshack/Manifest
+++ b/sci-geosciences/qmapshack/Manifest
@@ -1,3 +1,4 @@
DIST qmapshack-1.12.0.tar.gz 12030329 BLAKE2B af641e76b00ee7dc7d964fd9f4ba75e51d7d6bcc4b33e020129181655371cda91f8ddffdcfd489f55228c22fc63416e6e5c8f4b1755a6a07e5832895a921afc7 SHA512 dac6081b37eab39431221acdd48a3e61876ff40e4f76aac7eed9232e839cabc69a099cb2e9e29fcc23cf439eaa8a3d1522be17e24c71e2b6d3f332eb3127efb5
DIST qmapshack-1.12.1.tar.gz 12033026 BLAKE2B e898507bad42a141f02cf8fd0338cdf9f39344b249318be29d1e6eb500a9e810496c6a790745cf50aec0025b5547be8382ef0c9eab2d780cbf63f9d29eb064a9 SHA512 c9b6ad0c7372cc4d992cee07d20ee0ad5779014ce6336644e13be705ec0bbed22d5f83e27473c2813c5bf13e49558686546c50fd597eb9ef2692c64933f94713
DIST qmapshack-1.12.3.tar.gz 12029443 BLAKE2B 8d7f117c8379f7181ce68f79f460f59342cf654179c8b85839fe003e06167765e3e2292e14b4bc71c3ba1aeb388fcbb77faccdd57748335c1df8500f9e52ba41 SHA512 01a2b73f2f432a24b614c4a325e0b0a2aaf5b6ef75c5a7fbeb2be341adc7c46faa71cf7e9f4fdeb769d546b7a760be553a38ac6cc1c5c2c2d044edd37f550a85
+DIST qmapshack-1.13.0.tar.gz 12323773 BLAKE2B ea9cc15376546af442c6874e9321dfda268f523edb9908418baa4b3286339b4274f3c4694bebe036fb24ea3af82da1195d323c5e7484ca49039b9a526c29fa12 SHA512 cdc876a73d855573854691e3ef1d685499c9da381eb028e4a6e80dcd243df68caa66c92057fc1b896fce2be20e6d2ca43499b0e6827f804f27a0e8cc3749a100
diff --git a/sci-geosciences/qmapshack/files/FindPROJ4.cmake b/sci-geosciences/qmapshack/files/FindPROJ4.cmake
new file mode 100644
index 000000000000..093deaa79aed
--- /dev/null
+++ b/sci-geosciences/qmapshack/files/FindPROJ4.cmake
@@ -0,0 +1,152 @@
+#.rst:
+# FindPROJ4
+# --------
+#
+# Find the proj includes and library.
+#
+# IMPORTED Targets
+# ^^^^^^^^^^^^^^^^
+#
+# This module defines :prop_tgt:`IMPORTED` target ``PROJ4::proj``,
+# if Proj.4 has been found.
+#
+# Result Variables
+# ^^^^^^^^^^^^^^^^
+#
+# This module defines the following variables:
+#
+# ::
+#
+# PROJ4_INCLUDE_DIRS - where to find proj_api.h, etc.
+# PROJ4_LIBRARIES - List of libraries when using libproj.
+# PROJ4_FOUND - True if libproj found.
+#
+# ::
+#
+# PROJ4_VERSION - The version of libproj found (x.y.z)
+# PROJ4_VERSION_MAJOR - The major version of libproj
+# PROJ4_VERSION_MINOR - The minor version of libproj
+# PROJ4_VERSION_PATCH - The patch version of libproj
+# PROJ4_VERSION_TWEAK - always 0
+# PROJ4_VERSION_COUNT - The number of version components, always 3
+#
+# Hints
+# ^^^^^
+#
+# A user may set ``PROJ4_ROOT`` to a libproj installation root to tell this
+# module where to look exclusively.
+
+#=============================================================================
+# Copyright 2016 Kai Pastor
+#
+#
+# This file was derived from CMake 3.5's module FindZLIB.cmake
+# which has the following terms:
+#
+# Copyright 2001-2011 Kitware, Inc.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+#
+# * Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+#
+# * The names of Kitware, Inc., the Insight Consortium, or the names of
+# any consortium members, or of any contributors, may not be used to
+# endorse or promote products derived from this software without
+# specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER AND CONTRIBUTORS ``AS IS''
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR
+# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#=============================================================================
+
+# Search PROJ4_ROOT exclusively if it is set.
+if(PROJ4_ROOT)
+ set(_PROJ4_SEARCH PATHS ${PROJ4_ROOT} NO_DEFAULT_PATH)
+else()
+ set(_PROJ4_SEARCH)
+endif()
+
+find_path(PROJ4_INCLUDE_DIR NAMES proj_api.h ${_PROJ4_SEARCH} PATH_SUFFIXES include)
+mark_as_advanced(PROJ4_INCLUDE_DIR)
+
+if(PROJ4_INCLUDE_DIR AND EXISTS "${PROJ4_INCLUDE_DIR}/proj_api.h")
+ file(STRINGS "${PROJ4_INCLUDE_DIR}/proj_api.h" PROJ4_H REGEX "^#define PJ_VERSION [0-9]+$")
+
+ string(REGEX REPLACE "^.*PJ_VERSION ([0-9]).*$" "\\1" PROJ4_VERSION_MAJOR "${PROJ4_H}")
+ string(REGEX REPLACE "^.*PJ_VERSION [0-9]([0-9]).*$" "\\1" PROJ4_VERSION_MINOR "${PROJ4_H}")
+ string(REGEX REPLACE "^.*PJ_VERSION [0-9][0-9]([0-9]).*$" "\\1" PROJ4_VERSION_PATCH "${PROJ4_H}")
+ set(PROJ4_VERSION "${PROJ4_VERSION_MAJOR}.${PROJ4_VERSION_MINOR}.${PROJ4_VERSION_PATCH}")
+ set(PROJ4_VERSION_COUNT 3)
+endif()
+
+# Allow PROJ4_LIBRARY to be set manually, as the location of the proj library
+if(NOT PROJ4_LIBRARY)
+ set(PROJ4_NAMES proj)
+ set(PROJ4_NAMES_DEBUG projd)
+ if(WIN32 AND DEFINED PROJ4_VERSION_MAJOR AND DEFINED PROJ4_VERSION_MINOR)
+ list(APPEND PROJ4_NAMES proj_${PROJ4_VERSION_MAJOR}_${PROJ4_VERSION_MINOR})
+ list(APPEND PROJ4_NAMES projd_${PROJ4_VERSION_MAJOR}_${PROJ4_VERSION_MINOR})
+ endif()
+ find_library(PROJ4_LIBRARY_RELEASE NAMES ${PROJ4_NAMES} ${_PROJ4_SEARCH} PATH_SUFFIXES lib)
+ find_library(PROJ4_LIBRARY_DEBUG NAMES ${PROJ4_NAMES_DEBUG} ${_PROJ4_SEARCH} PATH_SUFFIXES lib)
+ include(SelectLibraryConfigurations)
+ select_library_configurations(PROJ4)
+endif()
+
+# handle the QUIETLY and REQUIRED arguments and set PROJ4_FOUND to TRUE if
+# all listed variables are TRUE
+include(FindPackageHandleStandardArgs)
+find_package_handle_standard_args(PROJ4
+ REQUIRED_VARS
+ PROJ4_LIBRARY
+ PROJ4_INCLUDE_DIR
+ VERSION_VAR
+ PROJ4_VERSION
+)
+
+if(PROJ4_FOUND)
+ set(PROJ4_INCLUDE_DIRS ${PROJ4_INCLUDE_DIR})
+
+ if(NOT PROJ4_LIBRARIES)
+ set(PROJ4_LIBRARIES ${PROJ4_LIBRARY})
+ endif()
+
+ if(NOT TARGET PROJ4::proj)
+ add_library(PROJ4::proj UNKNOWN IMPORTED)
+ set_target_properties(PROJ4::proj PROPERTIES
+ INTERFACE_INCLUDE_DIRECTORIES "${PROJ4_INCLUDE_DIRS}")
+
+ if(PROJ4_LIBRARY_RELEASE)
+ set_property(TARGET PROJ4::proj APPEND PROPERTY
+ IMPORTED_CONFIGURATIONS RELEASE)
+ set_target_properties(PROJ4::proj PROPERTIES
+ IMPORTED_LOCATION_RELEASE "${PROJ4_LIBRARY_RELEASE}")
+ endif()
+
+ if(PROJ4_LIBRARY_DEBUG)
+ set_property(TARGET PROJ4::proj APPEND PROPERTY
+ IMPORTED_CONFIGURATIONS DEBUG)
+ set_target_properties(PROJ4::proj PROPERTIES
+ IMPORTED_LOCATION_DEBUG "${PROJ4_LIBRARY_DEBUG}")
+ endif()
+
+ if(NOT PROJ4_LIBRARY_RELEASE AND NOT PROJ4_LIBRARY_DEBUG)
+ set_property(TARGET PROJ4::proj APPEND PROPERTY
+ IMPORTED_LOCATION "${PROJ4_LIBRARY}")
+ endif()
+ endif()
+endif()
diff --git a/sci-geosciences/qmapshack/files/qmapshack-positioning.patch b/sci-geosciences/qmapshack/files/qmapshack-positioning.patch
new file mode 100644
index 000000000000..c0f13fc884e5
--- /dev/null
+++ b/sci-geosciences/qmapshack/files/qmapshack-positioning.patch
@@ -0,0 +1,9 @@
+diff -U2 qmapshack-1.13.0.orig/CMakeLists.txt qmapshack-1.13.0/CMakeLists.txt
+--- qmapshack-1.13.0.orig/CMakeLists.txt 2019-04-08 18:08:10.000000000 +0200
++++ qmapshack-1.13.0/CMakeLists.txt 2019-05-06 23:19:15.330580322 +0200
+@@ -131,4 +131,5 @@
+ find_package(Qt5LinguistTools REQUIRED)
+ find_package(Qt5PrintSupport REQUIRED)
++find_package(Qt5Positioning REQUIRED)
+ find_package(Qt5UiTools REQUIRED)
+ find_package(Qt5Network REQUIRED)
diff --git a/sci-geosciences/qmapshack/qmapshack-1.13.0.ebuild b/sci-geosciences/qmapshack/qmapshack-1.13.0.ebuild
new file mode 100644
index 000000000000..a1e08508c620
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.13.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils xdg-utils gnome2-utils
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://bitbucket.org/maproom/qmapshack/wiki/Home"
+SRC_URI="https://bitbucket.org/maproom/${PN}/downloads/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtprintsupport:5
+ dev-qt/qtpositioning:5
+ dev-qt/qtdbus:5
+ dev-qt/qttest:5
+ dev-qt/designer:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-libs/quazip
+ >=sci-geosciences/routino-3.1.1
+ sci-libs/gdal
+ >=sci-libs/proj-5.0.0
+ sci-libs/alglib"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=( "${FILESDIR}"/${PN}-positioning.patch )
+
+src_prepare() {
+ default
+ cp "${FILESDIR}"/FindPROJ4.cmake cmake/Modules/ || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}