summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-04-02 05:16:35 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-04-02 05:16:35 +0700
commite80a1974963f3c3633ab857fb5e4e75cb83bc803 (patch)
treef2561ab7fa50ee7adacb451741734440dffd7e51 /sci-geosciences/routino
parentdev-java/jsr173: drop jaxme dependency. (diff)
downloadgentoo-e80a1974963f3c3633ab857fb5e4e75cb83bc803.tar.gz
gentoo-e80a1974963f3c3633ab857fb5e4e75cb83bc803.tar.bz2
gentoo-e80a1974963f3c3633ab857fb5e4e75cb83bc803.zip
sci-geosciences/routino: bump to 3.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/Manifest1
-rw-r--r--sci-geosciences/routino/files/routino-3.2.patch30
-rw-r--r--sci-geosciences/routino/routino-3.2.ebuild23
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index 85ab15fb76c1..1ba4e62bd8bb 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -1 +1,2 @@
DIST routino-3.1.1.tgz 1795118 SHA256 23b9fce43f0a85c9efe220c6c72026dd7b37f6a4a5153bb9dc4c4b0747c7f282 SHA512 088f22e9297f485418ed369d00827690f86e224e331b69085513339870fe6d97cffef62aa5e7e14883800469beff4af4b0a581ba8bad78920a383d7152be6ede WHIRLPOOL 914180a728120ba189ff9bc2bf51c64246f635f7cc2e6b6efecf4dbb2c76f9b61f6269225620b5a5204025c838a6fcd8ffc24953a8cf24c084edbbdfb24a6b58
+DIST routino-3.2.tgz 2463662 SHA256 e2a431eaffbafab630835966d342e4ae25d5edb94c8ed419200e1ffb50bc7552 SHA512 f5be46d9c026fcd92658490630d9ff6e4827e84ee57ccbaae48f54372da37ab78de24432ab9fa1d6860304a9a2ac86061eb876c12b39e821693282c4d4aaefcf WHIRLPOOL c30ea87987e60d5ef57591bcba8190ece3cc8acfba2cb62035785238119c0d84db65e9f53a2935d8cd2bb0c3d37cd9b8970e9c6ba897b0874f847db31f0858ee
diff --git a/sci-geosciences/routino/files/routino-3.2.patch b/sci-geosciences/routino/files/routino-3.2.patch
new file mode 100644
index 000000000000..484b61b68f10
--- /dev/null
+++ b/sci-geosciences/routino/files/routino-3.2.patch
@@ -0,0 +1,30 @@
+diff -r -U1 routino-3.2.orig/Makefile.conf routino-3.2/Makefile.conf
+--- routino-3.2.orig/Makefile.conf 2016-11-22 20:22:52.000000000 +0100
++++ routino-3.2/Makefile.conf 2017-04-01 23:58:23.835905270 +0200
+@@ -47,3 +47,3 @@
+ ifneq ($(HOST),MINGW)
+-prefix=/usr/local
++prefix=/usr
+ bindir=$(prefix)/bin
+@@ -51,3 +51,3 @@
+ libdir=$(prefix)/lib
+-docdir=$(prefix)/doc/routino
++docdir=$(prefix)/share/doc/$(PF)
+ datadir=$(prefix)/share/routino
+@@ -79,3 +79,3 @@
+ # Language dialect selection
+-CFLAGS=-std=c99
++CFLAGS+=-std=c99
+
+@@ -85,3 +85,3 @@
+ # Optimisation options
+-CFLAGS+=-O3
++#CFLAGS+=-O3
+ CFLAGS+=-ffast-math
+@@ -141,4 +141,4 @@
+ # Required for xz support (uncomment these two lines if required)
+-#CFLAGS+=-DUSE_XZ
+-#LDFLAGS+=-llzma
++CFLAGS+=-DUSE_XZ
++LDFLAGS+=-llzma
+
diff --git a/sci-geosciences/routino/routino-3.2.ebuild b/sci-geosciences/routino/routino-3.2.ebuild
new file mode 100644
index 000000000000..cb1ceff2cd3c
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="http://www.routino.org/"
+SRC_URI="http://www.routino.org/download/${P}.tgz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake -j1
+ rm README.txt
+ mv doc/rm README.txt .
+}