summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-28 21:58:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-28 22:30:18 +0100
commitf72e2eef382e12190f9e9cd5449a3b03b89b1bff (patch)
tree0d89e2ceacb1ba85797e892353e90f02571939eb /sci-geosciences/tappy/tappy-0.9.0-r1.ebuild
parentsci-geosciences/tappy: Permit scipy-python2 (diff)
downloadgentoo-f72e2eef382e12190f9e9cd5449a3b03b89b1bff.tar.gz
gentoo-f72e2eef382e12190f9e9cd5449a3b03b89b1bff.tar.bz2
gentoo-f72e2eef382e12190f9e9cd5449a3b03b89b1bff.zip
sci-geosciences/tappy: PYTHON_USEDEP, anyone?!
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-geosciences/tappy/tappy-0.9.0-r1.ebuild')
-rw-r--r--sci-geosciences/tappy/tappy-0.9.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-geosciences/tappy/tappy-0.9.0-r1.ebuild b/sci-geosciences/tappy/tappy-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..8f6ed281d6cb
--- /dev/null
+++ b/sci-geosciences/tappy/tappy-0.9.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit distutils-r1
+
+DESCRIPTION="Tidal Analysis in Python breaks hourly water level into tidal components"
+HOMEPAGE="http://tappy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ || (
+ dev-python/matplotlib-python2[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )
+ dev-python/pywavelets[${PYTHON_USEDEP}]
+ || (
+ sci-libs/scipy-python2[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"