summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-14 18:10:07 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-14 18:13:48 +0200
commitb0e14a96e113106c4bb092def32d5f4c5cf79d0d (patch)
tree6e979459c2251e57113d5b5756f470846675408f /sci-geosciences
parentgames-puzzle/gnome-taquin: bump to 3.30.0 (diff)
downloadgentoo-b0e14a96e113106c4bb092def32d5f4c5cf79d0d.tar.gz
gentoo-b0e14a96e113106c4bb092def32d5f4c5cf79d0d.tar.bz2
gentoo-b0e14a96e113106c4bb092def32d5f4c5cf79d0d.zip
sci-geosciences/geocode-glib: bump to 3.26.1, nominatim search crash fix
Due to API changes in Nominatim service (string vs integer return in JSON), searches sometimes may crash now with older releases. E.g. searching for "Europe" in gnome-maps crashes without the fix in this version. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/geocode-glib/Manifest1
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/Manifest b/sci-geosciences/geocode-glib/Manifest
index 8a1c932fbf81..82fbbaf03e9e 100644
--- a/sci-geosciences/geocode-glib/Manifest
+++ b/sci-geosciences/geocode-glib/Manifest
@@ -1,2 +1,3 @@
DIST geocode-glib-3.24.0.tar.xz 413536 BLAKE2B 37eebd39bb64d614af338e323b7c37c9bcf554d82b761c135326a9b2c0ab405901739ffe89f50c35932d162e4d2743a21caf4f446924c5d9f47bcf50eb11f4e8 SHA512 0e3910e99d164fdf5afd6befbcb7139a56779834fb1f2a318951c03e5196a31c4dafd7f88c37c7014377f15cd4d4b81e7080a440881e2c50aadaadf621abe3b6
DIST geocode-glib-3.26.0.tar.xz 75984 BLAKE2B 72d7655e1066c276663ce90082d40c353a3c11ca13e51cb1568180d39e6058df5e7729b2206b44539ed70bd7fb8afeb7d4c264f7a541ab9b9c80223bcab0a457 SHA512 d0924673b669a29d04ad5f1d70797e98b67af3bc85edd8870d21d22d18ec8f2b93a13f94226e295ccb3c6e83d1545bdd2361ebacdbb1928c06b8beed36759838
+DIST geocode-glib-3.26.1.tar.xz 75296 BLAKE2B 68e42868edfd73db94d16dcc754eea1ee736ad910c5180616ba351cc50b682cd3b7ea4a64c9e1296af315298f68ea850a1773c4a05955c1159a6038773aad184 SHA512 0eb8e8a668c3950d06e77a379d375e2297cf7d95435aa8212715ddc36c3a57a53192e75dd0c82a2f2e7e558ea0e903a477c9dfa54f8cd2805d048fe46265d621
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild
new file mode 100644
index 000000000000..018bb7e4086a
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/disable-installed-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test enable-installed-tests) # Actual installation to live system is sedded out, but we need this for running them in src_test
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ )
+ meson_src_configure
+}